[webif] Web Interface version 1.0.17 released

Status
Not open for further replies.

af123

Administrator
Staff member
#1
I've uploaded version 1.0.17 of the web interface package. Here is a list of the changes since version 1.0.16. See http://wiki.hummy.tv/wiki/Webif_release_notes for the full change history.

1.0.17 (07/10/2014)
  • Fix for scheduling series which span channels (based on work by, and patch from, prpr);
  • Fix schedule backup and restore for series which span channels;
  • Fix scheduling of events with % in their name;
  • Fix folder creation from schedule list;
  • Support changing folder for pending recording;
  • Fix width of toggle switches on settings page;
  • Add option to reset dedup in order to run it again on a folder;
  • Check connectivity to repository using ping in order to provide better error messages;
  • Fix display of certain network names on channel diagnostic page (patch from prpr).
 

cdmackay

Active Member
#2
Slightly surprised myself, by managing to reboot the box, via WebIF, whilst there was an active recording.

I was on the Diag page, and clicked the Reboot System button.

Is the WebIF supposed to stop me doing that? I had thought that it had done so before.

Is it possible, that if you go to the Diag page before a recording starts, then leave that page in your browser for a few minutes, until the recording starts, then click Reboot, that the check doesn't happen? i.e. if the check were done entirely locally on the client, based on the time the page was generated?

Or am I imagining the check, and in fact WebIF will let you do this? If so, perhaps an RFE to stop it, please? :)

thanks much, as ever...
 

Black Hole

May contain traces of nut
#3
If you are trying to reboot from the WebIF diagnostics, you may be trying to recover from a failed condition. There should be no absolute lock-outs from the diagnostic tools (although with appropriate warnings). Reboots from the EPG and scheduling pages (to promote a schedule modification into the active list) are a different matter.
 

peterworks

Ye Olde Bowler
#4
As of this release I am only getting a partial schedule page. Webif error log shows a runtime error.
Am unable to paste it into reply or upload a text file

Peter
 
#6
My two HDRs (1.02.32/CF2.17 and 1.02.29/CF2.12) have not updated from 1.0.16-4. Also Redring has not updated to 2.16.
Any ideas please.

David
 

Ezra Pound

Well-Known Member
#7
As of this release I am only getting a partial schedule page. Webif error log shows a runtime error.
Am unable to paste it into reply or upload a text file
I am also getting the partial schedule error

upload_2014-10-14_12-16-37.png

Code:
>>> Contents of /var/log/webif-error.log 998 bytes
Runtime Error: /mod/lib/jim/binary.tcl:108: expected integer but got "0x"
in procedure 'eventrow' called at file "/mod/webif/html/sched/sched.jim", line 231
in procedure '.00000000000000000012>' called at file "/mod/webif/html/sched/sched.jim", line 110
in procedure 'rsv aul' called at file "/mod/lib/jim/oo.tcl", line 48
at file "/mod/lib/jim/oo.tcl", line 65
in procedure 'binary' called at file "/mod/webif/lib/rsv.class", line 65
at file "/mod/lib/jim/binary.tcl", line 108
 

MontysEvilTwin

Well-Known Member
#8
My two HDRs (1.02.32/CF2.17 and 1.02.29/CF2.12) have not updated from 1.0.16-4. Also Redring has not updated to 2.16.
Your custom firmware versions are getting a bit old now. That might not be the problem, but I doubt if af123 is still testing package changes on these. If you don't want to update to the latest official/ custom firmware version (1.03.12/ CFW 3.00), for example if you don't use the portal and can't tolerate the laggy EPG with 1.03.xx firmware, then I recommend updating both machines to 1.02.32/ CFW 3.00: this version is still supported.
You could try a manual package update: in Web-If> package management, click on 'update package list from the internet' and then, when the updates are listed, click on 'upgrade all packages'.
 

peterworks

Ye Olde Bowler
#9
Hi,
My Webif error log is available in my dropbox account. I cannot post the link as I do not have enought posts yet.
However it is the same as the one you have posted and the screenshot shows the same amount of data as mine.
 
#10
Hi,
My Webif error log is available in my dropbox account. I cannot post the link as I do not have enought posts yet.
However it is the same as the one you have posted and the screenshot shows the same amount of data as mine.
I am also getting the partial schedule error

View attachment 1402

Code:
>>> Contents of /var/log/webif-error.log 998 bytes
Runtime Error: /mod/lib/jim/binary.tcl:108: expected integer but got "0x"
in procedure 'eventrow' called at file "/mod/webif/html/sched/sched.jim", line 231
in procedure '.00000000000000000012>' called at file "/mod/webif/html/sched/sched.jim", line 110
in procedure 'rsv aul' called at file "/mod/lib/jim/oo.tcl", line 48
at file "/mod/lib/jim/oo.tcl", line 65
in procedure 'binary' called at file "/mod/webif/lib/rsv.class", line 65
at file "/mod/lib/jim/binary.tcl", line 108
I am also getting a partial schedule as above which resolves itself if I delete all BBC schedules?

Web interface version: 1.0.17-2
Custom firmware version: 3.00 (build 2137)
Humax Version: 1.03.12 (kernel HDR_CFW_3.00)
 
#11
I am also seeing the partial schedule page as reported by others, it failed on the fifth entry in the schedule (CSI channel 5) https://flic.kr/p/ponoMx
Code:
Runtime Error: /mod/lib/jim/binary.tcl:108: expected integer but got "0x"
in procedure 'eventrow' called at file "/mod/webif/html/sched/sched.jim", line 231
in procedure '.00000000000000000026>' called at file "/mod/webif/html/sched/sched.jim", line 110
in procedure 'rsv aul' called at file "/mod/lib/jim/oo.tcl", line 48
at file "/mod/lib/jim/oo.tcl", line 65
in procedure 'binary' called at file "/mod/webif/lib/rsv.class", line 65
at file "/mod/lib/jim/binary.tcl", line 108
I deleted the schedule entry that was failing (via remote) but it then failed again a few entries further down the list (11th entry - Grand designs Channel 4+1)

I then readded (via remote) the CSI entry and the schedule display again failed on that entry
 
Last edited:
#12
Your custom firmware versions are getting a bit old now. That might not be the problem, but I doubt if af123 is still testing package changes on these. If you don't want to update to the latest official/ custom firmware version (1.03.12/ CFW 3.00), for example if you don't use the portal and can't tolerate the laggy EPG with 1.03.xx firmware, then I recommend updating both machines to 1.02.32/ CFW 3.00: this version is still supported.
You could try a manual package update: in Web-If> package management, click on 'update package list from the internet' and then, when the updates are listed, click on 'upgrade all packages'.
Doing it manually sorted it.
I'll try 1.02.32/CF3.00 when I get chance, I've been meaning to upgrade for ages.
Thanks,
David
 

Ezra Pound

Well-Known Member
#15
Here it is :-
Code:
humax# sqlite3 /var/lib/humaxtv/rsv.db ".dump"|grep Detec
INSERT INTO "TBL_RESERVATION" VALUES(9,3,196673,1413493200,'00000000000000',1800,0,41384,'i7New: Detectorists',0,0,0,0,0,0,0,4,50,'FP.BBC.CO.UK/MIB0UC','i7Detectorists','1FP.BBC.CO.UK/15CLK8|1FP.BBC.CO.UK/15CLK7|','1FP.BBC.CO.UK/15CLK9|',X'41000300D0314054D8384054A8A10000',0,40028,30);
humax#
 

Ezra Pound

Well-Known Member
#18
Probably not connected, but I have just noticed that the 'Top Bar' of all Web-If screens has gone a bit strange
upload_2014-10-14_23-53-37.jpeg

EDIT
This is only happening on one windows 8.1 laptop running Firefox 32, but it was O.K., not sure when it started
EDIT-EDIT
A re-start of FF has put the 'Top-Bar' back to normal, so not a problem
 
Last edited:

cdmackay

Active Member
#20
It's almost too trivial to report, but...

When I create a new folder, if I hit <return> after typing the name, the New Folder dialog disappears, but the folder is not created. It's only created when I click the Create button, rather than hitting <return>.

This occurs on the current version, but I've seen it for a while.

thanks...

Web interface version: 1.0.17-3
Custom firmware version: 2.23 (build 2035)
Humax Version: 1.03.12 (kernel HDR_1.02.32)
 
Status
Not open for further replies.
Top