1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Writeable NTFS

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by jack616, Mar 17, 2012.

  1. jack616

    jack616 Member

    I'm reading conflicting reports here about whether NTFS is or is not writable when using the NTFS-3g mod.
    (Yes I tried a re-install)

    I've just upgraded my firmware to V2.0 during which something went wrong and my virtual disk vanished.
    (A re-install of the package returned service to normal - so no big issue)

    However for the first time I tried a copy to an NTFS partition on the USB port only to discover it is not writable.
    I've found various messages here both saying it is - or that there is a "fix" or that it isnt .

    Can anyone update me on the actual status or provide a DIRECT link to the fix/bodge or whatever is needed to
    get this to work if it is possible?

    cheers
     
  2. fenlander

    fenlander Active Member

    I've never had any problems writing to NTFS - both on USB and to a share on my PC - since installing ntfs-3g. No bodges needed, but I suppose it is possible that something I haven't installed might conflict with the ntfs driver.
     
  3. Black Hole

    Black Hole Felonius Gru

    Agreed. If you have the ntfs-3g package installed (and presumably reboot) you should have full access. If not there's something broken and af123 might be along to suggest some diagnostics.
     
  4. jack616

    jack616 Member

    Thanks for the info - I do indeed have something strange going on after the V2.0 upgrade I did last night.

    I've just noticed the enc flag is no longer being cleared (even after re-installing the mod) and Ive had a crash (GREEN screen of death?) and the
    virtual disk vanished again.
    After an uninstall cold boot re-install coldboot sequence of some of the mods the virtual disk re-appeared
    with its contents intact (yet even FTP couldnt find it before)

    I'm starting to think I need to do a factory reset and clean install with the V2.0 from scratch.
    Hopefully that will enable writing too.

    Does anyone have any advice on that or things I would need to watch out for maybe?
     
  5. xyz321

    xyz321 Well-Known Member

    Is this an HD? If so, the mod packages can only be installed on a disk formatted to ext3 or ext2. A workaround would be to use a USB hub with two disks, one of which would contain the mod packages and the second disk would be formatted to NTFS.
     
  6. jack616

    jack616 Member

    hi x
    No its a HDR - so hopefully the actual install shouldn't be too problematic. I guess I'll just go for it and hope for the best.
    I'd best get the saved files off first thou...
     
  7. jack616

    jack616 Member

    OK _I've re-installed everything from scratch starting with a factory reset and re-install of the official firmware.

    I then added the mod firmware V2.0 (I did try 1.17 but the online file seems corrupt?)
    Performed a hard drive format and reset system options
    Installed webif and then betaftpd (the configure message never goes away on that - but I left ot 5 minutes before closing and it works ok anyway)

    I then installed ntfs-3g and cold reset. Tried a copy to USB from webif and remote controler - the response is the same as not having ntfs-3g installed
    i.e. A window opens saying something like : Cant write to this device because its file system is NTFS

    next step ntfsprogs package installed - same result
    (also tried scandisk & 2 different USB drives)

    After finding the ntfs-3g thread (I had to use google - the search here doesnt seem to pick it up) I'm left
    with a couple of questions:

    1. Is this still command line only ?
    2. Do I need to install other packages such as nfs or whatever to get ntfs-3g to work?

    If neither of the above it has the appearance of simply not hooking into the system to me
    or - am I fundamentally missunderstanding something about how to use it?

    Any suggestion welcome - I'd really like to get this to work
    thanks
     
  8. Brian

    Brian Administrator Staff Member

    I can't help you with your problem, but would like to point out that I had no problems finding the ntfs-3g thread using the search box at the top of the page, especially after ticking the "Search titles only box".
     
  9. Ezra Pound

    Ezra Pound Well-Known Member

    You could try the 'Bundle' rather than the package LINK HERE as it should have all required files with it
     
  10. xyz321

    xyz321 Well-Known Member

    Something is wrong here, it should only be necessary to install the ntfs-3g package, no reboots necessary.
    The ntfsprogs package provides additional utilities such as formatting a drive to ntfs but isn''t necessary for basic access to an ntfs drive.
    It is only "command line only" in the sense that there is no special support for it in the web interface. If working correctly it really should be plug and play (i.e plug in a usb drive formatted to NTFS and just use it).

    The only additional dependency 'busybox' will be installed automatically by the installer.

    Try plugging in an NTFS formatted USB drive, wait a couple of seconds then look at the log file rag.log. You should see something similar to the following near the end (the PID numbers will probably be different).

    Code:
    --------- Info for PID 1225 ---------
    1225: MDEV:      sdc1
    1225: ACTION:    add
    1225: Model:      HDR
    1225: Device:    /dev/sdc1
    1225: Modinit:
    1225: Waiting for disk to mount...
    1225:  mounted.
    1225:  /dev/sdc1 mounted on /media/drive2
    1250: fuse filesystem is available
    1250: Mounting /media/usb-drive2 using ntfs-3g
    1225: Scanning /media/usb-drive2 for packages/bundles
    
     
  11. jack616

    jack616 Member

    Thanks for the info guys:
    This is what I have in rag.log after a cold start no recordings etc -

    --------- Info for PID 285 ---------
    285: MDEV: sda2
    285: ACTION: add
    285: Model: HDR
    285: Device: /dev/sda2

    --------- Info for PID 277 ---------
    277: MDEV: sda3
    277: ACTION: add
    277: Model: HDR
    277: Device: /dev/sda3
    285: Modinit: /mnt/hd2

    --------- Info for PID 275 ---------
    275: MDEV: sda1
    275: ACTION: add
    275: Model: HDR
    275: Device: /dev/sda1
    277: Modinit:
    277: Waiting for disk to mount...
    285: Waiting for disk to mount...
    275: Modinit:
    275: Waiting for disk to mount...
    275: mounted.
    275: /dev/sda1 mounted on /mnt/hd1
    275: Waiting for modinit to complete.
    277: still waiting...
    285: still waiting...
    277: still waiting...
    285: still waiting...
    277: still waiting...
    285: still waiting...
    277: mounted.
    285: mounted.
    277: /dev/sda3 mounted on /mnt/hd3
    277: Waiting for modinit to complete.
    285: /dev/sda2 mounted on /mnt/hd2
    285: Running modinit.

    --------- Info for PID 734 ---------
    734: MDEV: sdb2
    734: ACTION: add
    734: Model: HDR
    734: Device: /dev/sdb2
    734: Modinit: /mnt/hd2

    --------- Info for PID 732 ---------
    732: MDEV: sdb1
    732: ACTION: add
    732: Model: HDR
    732: Device: /dev/sdb1
    732: Modinit:
    734: Waiting for disk to mount...
    732: Waiting for disk to mount...
    734: mounted.
    732: mounted.
    734: /dev/sdb2 mounted on /media/drive2
    732: /dev/sdb1 mounted on /media/drive1
    734: Waiting for modinit to complete.
    732: Waiting for modinit to complete.

    ------------------------------------------------------------------------------------------- LOG ENDS --------------------------------------

    At this point the log doesnt change - ie modinit presumably never finishes?
    No mention of ntfs at all.

    When I install ntfs-3g this is what I get in the pop-up window:
    (Followed by the config complete and tick)
    ----------------------------------------------
    >>> opkg install ntfs-3g
    Installing ntfs-3g (2011.4.12-3) to root...
    Downloading http://hummypkg.org.uk/hdrfoxt2/base/ntfs-3g_2011.4.12-3_mipsel.opk.
    Loaded FUSE module into kernel.
    Configuring ntfs-3g.
    -----------------------------------
    It then appears in the installed list in Webif

    By the looks of it the package it just isnt being hooked into the system correctly?

    Ezra - I can find the bundle but am not sure what you want me to do with it ...
     
  12. jack616

    jack616 Member

    The modinit log contains:

    === diag =================================================
    Filesystem Size Used Available Use% Mounted on
    /dev/root 16.2M 16.2M 0 100% /
    tmpfs 61.0M 20.0K 61.0M 0% /tmp
    tmpfs 61.0M 0 61.0M 0% /media
    /dev/mtdblock1 2.0M 516.0K 1.5M 25% /var/lib/humaxtv
    /dev/mtdblock2 2.0M 1.2M 812.0K 60% /var/lib/humaxtv_backup
    /dev/sda1 1011.4M 40.8M 919.2M 4% /mnt/hd1
    /dev/sda2 447.6G 39.9G 384.9G 9% /mnt/hd2
    /dev/sda3 9.8G 150.6M 9.2G 2% /mnt/hd3

    eth0 Link encap:Ethernet HWaddr xxxx - jack deleted address
    inet addr:192.168.0.9 Bcast:192.168.0.255 Mask:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:3 errors:0 dropped:0 overruns:0 frame:0
    TX packets:3 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:198 (198.0 B) TX bytes:192 (192.0 B)
    Interrupt:16

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)


    PID USER VSZ STAT COMMAND
    1 root 1248 S init
    2 root 0 SW [migration/0]
    3 root 0 SWN [ksoftirqd/0]
    4 root 0 SW [migration/1]
    5 root 0 SWN [ksoftirqd/1]
    6 root 0 SW< [events/0]
    7 root 0 SW< [events/1]
    8 root 0 SW< [khelper]
    9 root 0 SW< [kthread]
    10 root 0 SW< [kblockd/0]
    11 root 0 SW< [kblockd/1]
    12 root 0 SW< [khubd]
    13 root 0 SW< [kseriod]
    14 root 0 SW [pdflush]
    15 root 0 SW [pdflush]
    16 root 0 SW< [kswapd0]
    17 root 0 SW< [aio/0]
    18 root 0 SW< [aio/1]
    19 root 0 SW< [ata/0]
    20 root 0 SW< [ata/1]
    21 root 0 SW< [ata_aux]
    22 root 0 SW< [scsi_eh_0]
    23 root 0 SW< [scsi_eh_1]
    24 root 0 SW [mtdblockd]
    25 root 0 SW< [kpsmoused]
    27 root 1244 S {rcS} /bin/sh /etc/init.d/rcS
    73 root 0 SWN [jffs2_gcd_mtd1]
    74 root 0 SWN [jffs2_gcd_mtd2]
    120 nobody 932 S /usr/bin/dnsmasq
    125 root 812 S /sbin/utelnetd -l /bin/sh -p 23 -d
    144 root 1244 S {S90settop} /bin/sh /etc/init.d/S90settop start
    154 root 308m S /usr/bin/humaxtv
    291 root 0 SW< [kjournald]
    302 root 1248 S < {run-and-gun} /bin/sh /etc/mdev/run-and-gun
    311 root 1248 S < {run-and-gun} /bin/sh /etc/mdev/run-and-gun
    320 root 1248 S < {run-and-gun} /bin/sh /etc/mdev/run-and-gun
    355 root 0 SW< [kjournald]
    358 root 0 SW< [kjournald]
    362 root 1232 S < sleep 1
    387 root 1232 S < sleep 1
    388 root 1252 S < {modinit} /bin/sh /sbin/modinit
    395 root 1336 R < ps -w

    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168.0.0 * 255.255.255.0 U 0 0 0 eth0
    default 192.168.0.1 0.0.0.0 UG 0 0 0 eth0

    === reset_all ============================================
    === setup_directories ====================================
    === create_rcS ===========================================
    === setup_hostname =======================================
    === setup_hosts ==========================================
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168.0.0 * 255.255.255.0 U 0 0 0 eth0
    default 192.168.0.1 0.0.0.0 UG 0 0 0 eth0
    Interface: [eth0]
    IP: [192.168.0.3]
    === run_init =============================================
    Loaded FUSE module into kernel.
    Anacron 2.3 started on 2012-03-19
    Loading config file /mod/etc/mongoose.conf
    Normal exit (0 jobs run)
     
  13. af123

    af123 Administrator Staff Member

    It does look like modinit is never completing, but the modinit output looks good too.. Are you up for running a couple of command line utilities and posting the output? If so, start with

    Code:
    humax# ps
    
    This could happen if you have a startup script under /mod/etc/init.d/ that never completes.
     
  14. jack616

    jack616 Member

    I'm happy to give the command line a go but I'm not set up for it ... It must be 25 years since I last used telnet so youd need to walk me through ...
     
  15. jack616

    jack616 Member

    hang on I'm getting somewhere...
     
  16. af123

    af123 Administrator Staff Member

    If it's easier, run the ps diagnostic from the web interface and post the output.
     
  17. jack616

    jack616 Member

    OK _ some progress:
    Debugging rule number 1: When someone labels their product "beta" assume it can affect anything at all....

    the betaftpd package prevents ntfs-3g from working. I took a look under /mod/etc/init.d/ as suggested - the clue was in there.
    I can now copy from the internal drive to an external USB NTFS drive IF betaftpd is dissabled - which is nice.

    Some issues I discovered while trying to do this follow for anyone interested ( these are only problems depending on whether you're a developer or need the functions I guess and allowing for the fact I may now have a corrupt installation after using betaftpd so some may not affect other people)

    1. betaftpd doesnt complete when first installed - take note when it happens! - this affects other things whilst still allowing it to work itself
    2. dissabling betaftpd from webif moves it to the not installed list - whilst leaving it actually installed (it can be just turned back on) - this I suspect is a bad idea
    3. NTFS-3g When writing to the NTFS drive for the first time the HUMAX icon immeduiately clicks round to zero space - even for a partition not being touched - it then stays there
    4. HUMAX when restoring to factory - selecting format the drive does not actually format the drive - I know because files previously stored are still there
    5. HUMAX when formatting the drive from the options menu the drive is not actually formatted - see 4 - this is really bad IMO
    6. Security - be aware that the logs are recording the file names on your USB drives if you run secure systems - history data may be accessable if you get hacked
    7. NTFS-3g Pehaps irrelevant - it doesnt seem possible to copy off the virtual drive to the USB NTFS drive

    Some of these comments may be moot as I havn't had time to fully test but I figure it best to record them while I had them in my head.
    Thanks once more for the input .

    My next job is to re-install the portal (without betaftpd!) and see if the virtual drive vanishes again...

    I will say this - thanks to the work you guys are doing this freeview box is turning out to be one of the best TV boxes around.
    (Probably THE best)
     
  18. Black Hole

    Black Hole Felonius Gru

    Interesting, thanks
     
  19. af123

    af123 Administrator Staff Member

    How peculiar. I'll investigate later. Do you know if betaftpd was the latest version?
     
  20. jack616

    jack616 Member

    Hi Yes I used the latest downloads because I started all this with a problem and figured that would be best.

    In fact - when investigating remember I started with a faulty system. It may not even be a bug at all.
    What started me doing this was the network lockup issue followed by the virtual disk vanishing - I installed betaftpd to look for it when it suddenly came back including files.
    I discovered the file permissions had been changed and Filezilla was unable to change them back (or any permissions I could find -
    I knew filezilla could do this elsewhere because I use it a lot on my own web sites)
    This permission problem went away when I re-installed virtual disk but came be back again later.

    This vanishing drive only started happening after I installed and tried out the portal-xtra1 mod and used it. (something I'm repeating
    slowly tommorow to see if I can identify any issue)

    So the sequence as best as I can remember was:

    With firmware mod V1.15 installed discovered the network lockup issue
    Tried installing V2.0 which seemed to go ok to fix the crashing (which could have done anything to the box)
    Install the portal mod and use it for Sky TV
    Notice a problem with virtual disk (may not be portal connected of course)
    try to fix it by uninstalling and re-installing various mods
    eventually did the factory reset etc sequence as above

    With betaftpd turned off so far all is calm.

    hope thats helpful.