YouView DTR T2100 won't power on


New Member
I came home and my DTR T2100 was on with a blue light showing, but the TV wasn’t receiving a signal from it and it didn’t respond to the remote or any button presses.

I switched off the box’s power switch, but now when I try to switch it back on there is no power – nothing happens at all.
I’ve replaced the power pack but makes no difference.

I’m out of contract, and don’t mind buying a new box (the current one has served me well) but I want to see if there’s a way I can save the recordings.
Is it worth me opening up the box to see if I can spot a lose wire or blown capacitor etc?

If it’s not the disk at fault it could it possibly be transplanted in to a new (second hand) box?
If it’s not the disk at fault it could it possibly be transplanted in to a new (second hand) box?
That won't work for the HD recordings as they are encrypted and tide to the box they were recorded on.
IIRC the YouView boxes are buttoned down even more than that
Playable SD recordings can be extracted from the drive. The main issue that some have had is attempting to use tools that recognise EXT files but can't handle XFS formatted partitions.

The easiest solution is probably what you suggested in that thread and what MET also suggested many years ago
I tried a new power pack and no effect. I put in a new HDD (with the old power pack) and still no power. Any ideas what might be wrong?
I don't think we know enough about the DTRs to be able to comment. If it had been a HDD problem (other than a dead short), it would probably have started up in some way even if it then rebooted.

Inside the unit, despite it having an external power adapter, the DTR almost certainly has other power converter circuits to produce a variety of voltages and separate voltage rails. Maybe one of those has dropped out, possibly because of capacitor rot, but it's a stab in the dark.