1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Customised Firmware 2.00

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by af123, Feb 23, 2012.

  1. af123

    af123 Administrator Staff Member

    I've uploaded version 2.00 of the customised firmware and it's available at the usual place (http://wiki.hummy.tv/wiki/Firmware_Downloads#Customised_Firmware).

    There aren't any significant changes or new features in it but it has been stable for a while now so I've tidied up a few bits that were on my todo list and finished the reset feature and moved it to version 2.

    The next webif package release will re-introduce the method of affecting a complete custom environment reset as long as this firmware version is installed.
     
    makem and 4291 like this.
  2. Wallace

    Wallace Slightly Pickled

    Installed and running sweet. Thank you once again.
     
  3. 4291

    4291 Well-Known Member

    Ditto :)
     
  4. Black Hole

    Black Hole Felonius Gru

    Gimme a few weeks...
     
  5. CK2011

    CK2011 Member

    Thanks af123, all your work is appreciated :)
     
  6. makem

    makem Member

    Diagnostics:

    'Remove all custom firmware packages and settings' is greyed out

    (This option will return with firmware 2)

    I have firmware 2 installed.
     
  7. Brian

    Brian Administrator Staff Member

    But have you also got webif version 0.9.3-4 installed.;)
     
  8. Wallace

    Wallace Slightly Pickled

    @makem

     
  9. Climber

    Climber Member

    Working fine on both HD and HDR boxes. Thank you
     
  10. 4291

    4291 Well-Known Member

    Strange behaviour going on here.

    I noticed this morning that the Humax was in standby with the HDD active as if waiting for a recording to start. I had nothing scheduled and the box should have been off.

    I could access the Webif but there was no recording showing. I switched the box out of standby and browsed the media files and, lo and behold, most of my recordings have been decrypted DEC.

    Is this automatic now?
     
  11. 4291

    4291 Well-Known Member

    I have had another look and all my recordings, including those in folders, are showing the DEC flag. None of them have the HD flag although some where recorded in HD.
     
  12. 4291

    4291 Well-Known Member

    Selecting any file brings up in Media Details:

    Runtime Error: file.jim:67: expected integer but got "" at file "file.jim", line67
     
  13. af123

    af123 Administrator Staff Member

    No, decryption isn't automatic now, nothing has changed significantly.

    That looks like your .hmt files are missing or corrupt in some way.. but nothing in v2 or the latest web interface should have done that. Can you check via FTP or some other method?
     
  14. Black Hole

    Black Hole Felonius Gru

    That sounds very odd on an HD-FOX! Unless af has been keeping something ground-breaking under his hat!
     
  15. 4291

    4291 Well-Known Member

    Looking back on what I did this morning.

    Upgraded Webif. All seemed OK.

    Selected "Update package list from Internet"
    In "Package Management Results" I got a Popup: http://192.168.0.xxx, OK.
    Selected OK and Processing Request began. It failed to finish so after several minutes I closed the box.
    Result: Under the Upgrade tab I get.

    Package Installed Avail Description Action
    Collected...............................................Install

    Dare I select Istall? :confused:
     
  16. CK2011

    CK2011 Member

    I updated last night to v2.00 & all was OK, this morning however I switched it on & it took me through a fresh installation as if I had just purchased it i.e. scanned for new channels etc.

    All scheduled programs were of course gone which is not a problem as custom firmware is still in place so I could restore.

    Just thought I would mention it in case anyone else reports the same, it maybe something completely unrelated to v2.00 being installed & just happened to be a coincidence.
     
  17. 4291

    4291 Well-Known Member

    Update to post #11

    All my packages in Package Management /Installed have Install against them instead of Remove.
    BootHDR still works though. If I Telnet in and boot into HDRmode then reboot, if I then look a my recordings in Webif > Browse Media Files everything appears normal, no DEC flags. When I close the browser then open Webif again, all the DEC flags are back.

    BTW, I did select Install Connected but it didn't seem to affect anything. Connected was already at the bottom of my Installed list.
     
  18. af123

    af123 Administrator Staff Member

    I'm sure that is a coincidence. v2 isn't a major change and there haven't been any other reports. The automatic schedule backup has saved me on occasion too!
     
  19. af123

    af123 Administrator Staff Member

    Can you try clearing your browser cache? This all sounds very odd and I can't think of a single reason that could explain all of your symptoms.
     
  20. 4291

    4291 Well-Known Member

    Fired up my Netbook and tried the two browsers I have on there, FireFox and Opera. Same result.