Film Names have disappeared, replaced by synopsis

Switching off sharing was probably the key. Either the sharing database is corrupt in which case you can reset it via the Web Interface Diagnostics screen or there is something on the network that is crashing the Humax (usually a Twonky server)
I haven't proved it yet, but I believe that an mkv file that the humax can't play properly, when it tries to index it in content sharing, will also cause the Humax in my case to become unresponsive to the remote and front panel buttons and only a webif reboot or power off/on can restore it, making sure to turn content sharin off again befreo it tries to index the same file.

As I said, I haven't proven this yet, but I think it was the cause of my problems with content sharing. I must get round to testing that theory out sometime.

So Everything is working fine, Trixes WiFi Wireless USB Adaptor Fast 150MBPS from installed, static IP address working.
As soon as I switch 'Sharing On' in the HDR, the thing restarts automatically.
I've managed to decrypt one half hour program.
All the time that 'Share' was off, between last crash on Tuesday until Saturday am. no crashes, then roughly 17 minutes :oops:
Humax crashed at Tue Aug 6 18:56:59 GMT 2013 - Uptime: 1047
Humax crashed at Sat Aug 10 09:35:24 GMT 2013 - Uptime: 1074
Humax crashed at Sat Aug 10 12:35:03 GMT 2013 - Uptime: 10752

Below are the packages that I have installed, any ideas will be appreciated.

auto-unprotect, auto-update, betaftpd, channeldel, disable-dso, disable-ota, ffmpeg, inadyn, ir, ntfs-3g, portal-xtra1, poweron-channel, redring, rs, samba, screensaver-glass-blue, undelete, webif, wireless-helper.
As soon as I switch 'Sharing On' in the HDR, the thing restarts automatically.
Probably something else on your network that is crashing the Humax DLNA server; later versions of Twonky are the most common cause and Power DVD has also been implicated.
I don't have either of those programs, the wireless stuff I have are 3 laptops, Toshiba L450, Toshiba Satellite C670, Toshiba Satellite A30 and a Shuttle XPC SB75G2, Shuttle XPC ST61G4, A Canon MG5250 wireless printer and a Canon ix6550 connected through a laptop as a network printer, a Sony BDP S573D 3D Blue-Ray player with built in wireless, LG TV with LG's wireless dongle, and the Humax HDR of course.

Come to think of it the sensible thing to do would be to kill everything and then switch things on one at a time? :rolleyes: doh!
I think I'll do that now and report back once something is isolated.
Everything switched of, shut down and Sony unplugged:
Humax crashed at Sat Aug 10 15:21:11 GMT 2013 - Uptime: 8232
Humax crashed at Sat Aug 10 15:39:12 GMT 2013 - Uptime: 1050
You could try leaving 'sharing = on' but disconnect the USB Wi-Fi dongle, if the Humax still crashes then there must be something else on your LAN that you didn't remove, to summarise you need to do test 3 below :-

test 1) sharing turned off = Humax does not cash
test 2) Sharing on + all other LAN items removed
test 3) Sharing on + USB Wi-Fi (and LAN) cable removed = not yet tested

If test 3) Prevents the Humax from crashing then you need to find out what is connected to your LAN that you missed in test 2, you can do this by setting up test 2 again and the plugging in a P.C. to your LAN then Start >> Run >> cmd and inserting the text below, after a Minute or so you will get another window displaying everything found on your LAN and 'Test Finished' in the cmd window, Note if your Humax is on say then replace 10.0.0.%a with 192.168.2.%a :-

(for /l %a in (1,1,254) do @PING 10.0.0.%a -n 1 -w 50 | find /i "reply")>log.txt
start log.txt
Test Finished

You then need to identify all the items it finds, the ipconfig will tell you what IP address you P.C. is using, In my case :-

Reply from bytes=32 time=61ms TTL=128
Reply from bytes=32 time<1ms TTL=128
Reply from bytes=32 time=2ms TTL=64

2= my router, 100 = the laptop running the script and 200 = my Humax

Note :- Thanks to Dragon-it for the cmd script
Thanks for quick reply Ezra Pound.
Sharing on, internet connections removed (only Dongle being used).
HDR crashed after about 17 minutes
That was not what I expected to find, should I try a cable connection to the router?
Sharing on, internet connections removed (only Dongle being used).
Not sure what the line above means, are you saying you was using the LAN connector as an internet connection AND a Wi-Fi USB dongle at the same time?
Just to be clear, you can't connect the LAN connector to a wired LAN at the same time as using a USB Wi-Fi Dongle because the Humax won't support two LAN connections simultaneously. If you are saying that the Humax still crashes when both the LAN cable AND the USB Wi-Fi dongle is removed, but is O.K. when 'sharing' is switched off, the only thing I can suggest is that the Humax is tying to use 'sharing = on' to decrypt a recording and that is what is causing the crash, If this is the case, disabling any auto-decryption should stop the crashing, until you can identify which recording the Humax can't decrypt
No Ezra Pound that's not what I meant.
When I first got the Custom Software I used a cable to the router while I waited for the Dongle to come from
When the Trixes arrived I disconnected the cable and connected the Dongle which installed without problems.
On the HDR in internet setting with just the dongle connected:
Configure Wi-Fi
Configure LAN(Wi-Fi)
Content Share OFF
FTP Server OFF

Does all that seem OK ?
Do I understand correctly that the Content Share only affects decryption for copy purposes ?
I've switched off auto-unprotect and turned sharing on
Any help appreciated.
Humax Built-in the Content sharing option so that the Humax could stream video to other Humax boxes and anything else that can act as a DNLA client, however the Custom Firmware also uses 'content share = on' to do it's decryption, by fooling the Humax into thinking it is steaming video to another box. I presume then, that "internet connections removed" means removing the link from your router to a broadband connection. I'm still not sure what the result of test 3) was, you need to have sharing = on and the USB dongle (and LAN cable) removed, does the Humax crash when in this state? if it does, then the content share may be crashing because of a failing Custom Firmware auto-decrypt
decryption by copying recordings to a USB drive does not require content share = on, only the decrypt in place (auto decrypt) needs it
Sorry my line:
"Sharing on, internet connections removed (only Dongle being used)." was drivel.

Only (Dongle being used) meant that I am now only using the dongle, not LAN.
I should have said:
Sharing on, internet connections removed.
HDR crashed after about 17 minutes.

I have since removed Custom Firmware auto-decryp, Content sharing on and the HDR crashed again.
Another step, you must be sick to death of Newbies
There appears to be a fault in the crash.log
The Humax crashed at 19:51, the log shows 18:51 another reboot at 20:09 showing as 19:09
Humax crashed at Sat Aug 10 18:51:49 GMT 2013 - Uptime: 1094 (actual reboot time 19:51)
Humax crashed at Sat Aug 10 19:09:21 GMT 2013 - Uptime: 1025 (actual reboot time 20:09)
This laptop and the Humax EPG time is correct, does that show anything.

In your BTW Ezra you state that decryption by copying recordings to a USB drive does not require content share = on, only the decrypt in place (auto decrypt) needs i. Does this include HD if I want to play it on my AC Ryan PlayOnHD or PC. ?
If the Humax crashes with the USB Wi-Fi dongle removed, the LAN cable disconnected AND auto-decrypt disabled, there are only a few thing s left I can think of, Do you have any recordings that have a 'lightening Bolt' icon against them or may be just a recording that will not play? corrupted files like this have been known to make the Humax crash when they are worked on.

As stated a copy of a recording to a USB drive (using the Remote control OPT+ copy function) will decrypt the recording, If auto-unprotect is installed, the hi-def. files should have the 'ENC' icon removed, when this icon is removed the Hi-Def. files can also be decrypted using the same copy to USB function
I have copied a HD file using a USB stick as a test, and can play it on the PC using VLC. I see it's a TS file so I'm gonna try Handbrake to mkv or mp4 it.
Next big test will be the cropping of adverts!
Thanks for all the help.
Just to be clear, does the Humax not crash with Content Share = Off? And it does crash if Content Share = On and the network disconnected?

If that is that case, it would appear that something on the Humax's own disk is upsetting the DLNA indexer. Shift all your content (or at least anything you want to keep) off the Humax (and delete anything else), then try Content Share = On again. If it now does not crash, you know where the problem was. Put stuff back a bit at a time and if it crashes you have located the problem file.
It's worth clearing the content sharing internal database first in case there's corruption. There's a guided option to do that in the web interface under Diagnostics->DLNA

Posted on the move; please excuse any brevity.