HDR-FOX T2 to HDHomeRun, my journey

Unfortunately I don't have any iPads to test on. If you have the option to change it then on the iPad make sure it is requesting a desktop version of the site, other than that I'm not sure what the issue is. Hopefully it should work okay using the search and 'programs by channel' to set up recordings as those pages are much simpler mark up. If the changes are also coming to Chrome then it may break for me as well in which case I can find the problem and fix it.
Guide now displays correctly on IOS17.1 public beta 3, hopefully it will still work when IOS17.1 is released.
 
  1. Stop the DvrOnTime service manually
  2. Copy the database files for C:\Program Files\DvrOnTime called DvrOnTime.mdf and DvrOnTime_log.ldf to another location
  3. Retune
  4. Copy over the database files with the those from step 2
  5. Restart the service
If I want to retune, will the above keep my recording schedule?
 
If I want to retune, will the above keep my recording schedule?
Yes it will keep the recording schedule, not sure what the numbered instructions relate to however, but you can just retune anytime using the option under Settings. The recording schedule will all go to "Pending..." immediately after a retune but as the guide repopulates they should all have times again. The only time some schedules may not be set again is where the channel has a new service identifier, this happened recently with BBC HD when they moved to a regional service on HD, so it would just be the case of doing a search for that program again and setting it then deleting the one stuck at "Pending...".
 
Thanks for the reply, forgive me for been thick, but are you saying there is no need to copy the database? Just retune and the recording schedule ill still be there?

I can't thank you enough for the programme
 
Thanks for the reply, forgive me for been thick, but are you saying there is no need to copy the database? Just retune and the recording schedule ill still be there?

I can't thank you enough for the programme
Yes, absolutely no need to copy the database, I'm not sure where those instructions originated from. The database holds the tuning information so if you copied back the original database you'd end up back where you started with the same tuned channels :)
 
The retune is complete

Right, one of the reasons I wanted to retune is because I'm having problems with the Drama channel. Nothing records from it. The Recording schedule says "The program is currently been recorded" and a directory is created, but it's always empty and Adbreaker doesn't register the recording either.

Drama records fine on the Humax, so I don't think it's me. Anyone know where to look to see what's going on?
 
Last edited:
The retune is complete

Right, one of the reasons I wanted to retune is because I'm having problems with the Drama channel. Nothing records from it. The Recording schedule says "The program is currently been recorded" and a directory is created, but it's always empty and Adbreaker doesn't register the recording either.

Drama records fine on the Humax, so I don't think it's me. Anyone know where to look to see what's going on?
I can confirm the issue with recording on Drama, I atach the log file which shows Call the midwife as recording but the directory is empty 😒
 

Attachments

  • eventlog1203.txt
    6.9 KB · Views: 2
I can view Drama live via the HdHomeRun so no problem with the homerun

I have been able to record Drama+1 (channel 60) so that would provide a workaround for now,
Updated log file
 

Attachments

  • eventlog1203b.txt
    11.2 KB · Views: 2
Glad it's not just me. And I too can view the live channel. I don't know if this is a recent problem as I don't think I have tried to record Drama until I saw Signora Volpe. Thanks for the tip about Drama+1
 
Last edited:
@lc200 Hope you can shed some light on these errors.

03/12/2023 21:09:33 Debug Thread running EPG is alive
03/12/2023 21:09:38 Debug Thread running EPG is alive
03/12/2023 21:09:43 Debug Thread running EPG is alive
03/12/2023 21:09:47 Warning => Corrupt packet total 10 (logging of corrupt packets suspended for 1 minute)
03/12/2023 21:09:48 Debug Thread running EPG is alive
03/12/2023 21:09:53 Debug Thread running EPG is alive
03/12/2023 21:09:56 Warning => Corrupt packet total 3 (logging of corrupt packets suspended for 1 minute)
03/12/2023 21:09:58 Debug Thread running EPG is alive
03/12/2023 21:10:03 Debug Thread running EPG is alive
03/12/2023 21:10:08 Debug Thread running EPG is alive
03/12/2023 21:10:13 Debug Thread running EPG is alive
03/12/2023 21:10:13 Error System.IndexOutOfRangeException: Index was outside the bounds of the array.
at TransportStream.Table.GetTableInPacket(Packet packet)
at TransportStream.Table.ProcessPacket(Packet packet)
at DvrOnTime.ProgramRecordByEit.Tuner_PacketReceived(Object sender, EventArgs e)
at HdHomeRun.TunerDevice.PacketExtract(Byte[] data)
at HdHomeRun.TunerDevice.TcpReceiver(Object data)
03/12/2023 21:10:13 Information Streaming stopped on device 1250E143 tuner 2


I seem to be getting a lot of the corrupt packet errors in the log file. I have 2 Quatro's and both they and the PC doing the recording are all hardwired to the switch.

The error stopped the recording 10 mins in (shows as no error in the recording log!) and even worse than that 2 subsequent recordings on the same channel (c4 SD) failed to start and are shown as warnings in the recordings schedule. Any ideas/suggestions?
 
@lc200 Still having recording problems which seem to be related to the corrupt packets. I would appreciate some insight into the potential causes of these errors. For now I changed the priority on my Quatro's to see if that makes any difference. As mentioned before if I get an error on a channel a particular timeslot, subsequent recordings on that channel at later timeslots also seem to fail...
 
Back
Top