[network-shares-automount] package released

I was wondering if Mihaid tried mounting the NAS after uninstalling and reinstalling cifs, samba and network shares automount but before installing zeroconfig? Zeroconfig could be a red herring.

I didn't.
The devil on my shoulder is telling me go and uninstall zeroconfig, but I've struggled so much with this to work so I won't do it. I'm of the opinion that if it ain't broke don't fix it. Presumably zeroconfig does not have any detrimental effect.
Yup - if it is ZeroConf, it could be that it just caused some broken network config to get fixed, as Black Hole suggested. Either way, good news that it's finally working :)
Well, because of something broken, I uninstalled zeroconfig and the mount is still working as some suggested. That also fixed my problem.
I've been trying to get the wake up lan function to work, but haven't had any success.

I've tested and are able to wake the computer from my laptop, just not from the Humax. - When the computer is on, the shares work fine.

I've tried using wakenow and wakeconstantly.

I couldn't find any specific details about the format that the mac address needs to be? Am I correct aa:bb:cc:dd:ee:ff format should be converted too nopaces aabbccddeeff or should the colons be included? Is there anything else I can do to get WOL working?

This might help (although the WoL functionality has been revised since then):

Thanks. That's what I'm using at the minute. I read the log and the script is being followed, it shows it's trying to wake the PC but doesn't succeed. With wake constantly even. I thought I'd check to make sure I'm doing it correctly. Just in case it was supposed to be underscores instead.

Not sure where to go from here, maybe a problem with the script this function directs too. It's well above my technical knowledge to change that for sure. Hoping other people who may use it may have some advice!
I don't think WoL has been much used, there certainly has not been a lot of discussion about it. You will need to review the topic for updates to the WoL functionality.
Wow, what a thread! I have set up my NAS and Hummy, and am able to see the NAS from the hummy on SMB.
The one thing that doesn't quite work is mounting subfolders on the NAS.
i.e. I have video, pictures, music folders that I can see. Within video, I have created 'TV' and 'Film' folders. I would like to mount these two dirs separately.
so for one, I have:
host= (my NAS location)

However, this doesn't work (cannot find specified directory).if folder=video, then it does work, but mounts at that point.
Can you help?
Ah yes, thanks BH for the advice. It's a bit clunky imo, as I'll have loads of shares at base level, but never mind (I have kids stuff, my own stuff, wife's own stuff), it looks like it'll work unless a better solution pops up..

also, I managed to get in and edit the package, so now I have a [NwkSettings] folder, more descriptive than ModSettings. Plus my shares folder is now a_NAS, so is at the top of the list, above my a_usb mount! All I have to do now is wait for the 'dear, I accidentally deleted that folder you told me not to'...
I came back from holiday to find out that the t2 does not automount my nas anymore?
the log says is on-line - attempting to mount NAS
mount -t cifs // /media/NAS -o user=admin,password=pass,domain=WORKGROUP,unc=\\\Public
mount: mounting // on /media/NAS failed: No such device
Mount failed...
umount: can't forcibly umount /media/NAS: Invalid argument

I have rebooted the t2. What else can I try?
installed zeroconf, it did not fix it
uninstalled samba /network shares/ cifs then installed network shares and samba and voila, it works.
uninstalled zeroconf. as others said it was a red herring.

puzzled as to why it would stop working in the first place.
Can somebody please tell me what I've got wrong at this point? Too many hours disappearing in failure!

mac=ABABABABABAB (only needed for wakeUp)

But all I'm getting in the log is:
2148 ping: sendto: Network is unreachable
2147 umount: can't forcibly umount /media/Mini2: Invalid argument
2146 Mount failed...
2145 mount: mounting // on /media/Mini2 failed: Invalid argument
2144 mount -t cifs // /media/Mini2 -o user=humax,password=humax,domain=home,unc=\\\ForStreaming
2143 is on-line - attempting to mount Mini2

At least I've now got something appearing in the log, it took a while for anything to happen there at all.

As an alternative, I'm also trying the following nfs mount:
mac=ABABABABABAB (only needed for wakeUp)

/etc/exports on the host is:

/Users/***/Movies/ForStreaming -ro

Where is the host, and is the HDR. And the nfs attempt appears to produce nothing in the scanmount log at all...

Any help greatly appreciated!
Well, I wouldn't be using shareFolder=on. The mount will be treated as an extension to the internal HDD, and all the Humax processes will include it - eg walking it for the DLNA indexer. Slow!

Having shareFolder=off, however!,means accessing the share via Media >> Storage (blue) >> USB, and in order for that to work at all you need a real USB device connected or to be running the virtual-disk2 package.
OK - I didn't realise I could stick in a 'virtual disk', was put off by the idea of tying up a USB device and/or slot. I shall install virtual-disk2 and adjust accordingly.
Both nfs shares have now, for some reason, popped up - so at least that bit is working, and I can give up on the failing duplicate smb share...