• The forum software that supports hummy.tv has been upgraded to XenForo 2.1!

    This is upgrade brings a number of improvements including the ability to bookmark posts to come back to later. Please bear with us as we continue to tweak things and open a new thread for any questions, issues or suggestions in Site/Forum Issues.

[network-shares-automount] package released

MattyGroves

New Member
Resolution of NFS connection problem from HDR Fox T2 to Zyxel NAS

Just in case this is of any help to anyone...

I recently acquired an HDR Fox T2, and while it took about 2 minutes to install the custom firmware, it took most of the morning to work out how to connect via NFS to my ZyXEL NAS 310. I could access the ZyXEL via NFS without any problem on my PC and on my WDTV Live streaming box, but every time I tried to connect via the Humax I kept getting errors in the scanmount log along the lines of "Permission denied" and "Bad file descriptor". I was using the same IP number and folder details that worked for the WDTV, but it wasn't working. I then spent a long time trying all sorts of different folders / directories but just could not work it out. I could have tried accessing the NAS via Samba, of course, but I did not want to be beaten, and in the past NFS always worked much better over my network.

Anyway, the solution may be obvious to those familiar with Unix / Linux and the workings of NFS, but it wasn't to me, so in case it is of any help to anyone - the problem was to do with the NFS server on my ZyXEL NAS. When I had first set up the NFS server on the NAS (or at some early point), the NAS had created an "etc/exports" file - that is a file called "exports" in the directory "etc". This file sets the access settings for the server. When I telnet-ed into the NAS, the exports file was restricting access to (I think) a single IP address - I don't really understand CIDR (the syntax of specifying the IP range). Anyway, it looks like both my desktop and the WDTV streaming box were ignoring this file, which is why I didn't think there were any access restrictions in place. Anyway, I edited the IP address from a single IP address to a range of IP address from .64 to .127 (by typing in "192.168.0.64/26" in case you are interested), and then everything began to work just fine.

I can provide more detailed information if anyone wants it.
 

MattyGroves

New Member
Just to follow up on the last message - I now see that the ZyXEL NAS admin section allows you to set the IP filter, so if anyone has a similar problem you don't need to faff about with telnet-ing into the NAS or trying to use various Linux text editors to edit the etc/exports file.

While I am at it, having managed to mount the drive, I then thought I would follow advice I read elsewhere regarding whether or not to set the ShareFolder flag to On or Off. I didn't want to have to stick a USB drive in to see the folder, so I was tempted to set the flag to ON, but some had suggested that this could slow down the Humax as it would then attempt to index my entire NAS. The suggestion was to use Virtual Drive 2, but I couldn't see the package anywhere on the Package Management screen. It turned out that to see that particular package (along with many others) I had to go to Settings / Advanced Settings and set "show development and advanced packages" to Yes.

Now all is working fine, although Virtual Drive 2 seems to virtual add the drive about 30 seconds after turning on the Humax, and a little screen pops up. But that's a small price to pay
 

Black Hole

May contain traces of nut
I don't understand why you would want to avoid £5 (or less) invested in a UPD to permanently reside in one of your (presumably unused) USB sockets. You might already have several laying around surplus to requirements. All my HDRs are so equipped, and it avoids all that trouble. After all, the socket at the back is a pain to get to for casual use.

(Not only does putting the NAS in the My Video path mean the DLNA server has to index it periodically, it also upsets the free space calculations and makes the NAS content far more prone to being accidentally deleted!)
 

MontysEvilTwin

Well-Known Member
Sometimes I watch recordings stored on another HDR-FOX, accessed on the local machine with the remote location mounted by network shares automount. On occasion I find, on reopening a network location, that there are no recordings or subfolders listed under the share. This may be due to the network dropping briefly, but once it happens I have found that the local machine needs to be rebooted to re-establish the share correctly, which is not always convenient. Is there simple way of disconnecting and reconnecting the individual share and/ or all shares from the command line?
 

Black Hole

May contain traces of nut
I find this too. If the remote machine isn't listed at all, that end needs rebooting; if it is listed but empty, this end needs rebooting.
 

MontysEvilTwin

Well-Known Member
As an example when the remote 'My Video' folder is mounted as '/media/HDR1' unmounting the share as follows:
Code:
umount /media/HDR1
simulates the situation I described in post #664: the share 'HDR1' is still listed (with the remote control, >MEDIA>Storage (blue)>USB (right, OK) but without contents. I presume that if this vestige of the former mount were removed then Network Shares Automount would remount the share.

I get post #666! Spooky.
 

MontysEvilTwin

Well-Known Member
I have had some success. I looked in 'Scanmounts.log' and the automount entry for the NFS share (HDR1) was as follows:
Code:
mount -o soft 192.168.0.6://media/My Video /media/HDR1
I unmounted the remote share:
Code:
umount /media/HDR1
and tried to remount using the above Scanmounts entry without success. However enclosing the 'My Video' in the path with quotes worked and the contents became available again:
Code:
mount -o soft 192.168.0.6://media/"My Video" /media/HDR1
I tried similar with an SMB share, using the entry from Scanmounts.log but I have not been able to make it work, presumably due to incorrect syntax.
 

Black Hole

May contain traces of nut
What about just changing the name of the mount in the Modsettings folder structure. Maybe that would force automount to re-mount it?
 

MontysEvilTwin

Well-Known Member
What about just changing the name of the mount in the Modsettings folder structure. Maybe that would force automount to re-mount it?
I think your suggestion would work but there is an even simpler way. It is the dead sharefolder under 'media' that stops Network Shares Automount from working. If you rename this folder, then the original share is recreated automatically. The dead sharefolder is removed when the system is rebooted or put into standby.
 

chimeland

New Member
Hi folks, I wonder if anyone could advise regarding a frustrating problem with an NFS mount please.

I'm accessing an NFS share on my NAS/server via the USB list but I can only see the first (top) level of files and folders under the mount. All folders appear empty. An MP4 visible on that top level that plays directly on the T2 and via DLNA does not play when accessed via the USB list, with an error of "Cannot support this file format".

I've tried altering the NFS share options on the NAS (such as "nohide" and "no_subtree_check") but to no avail. I have no problem accessing the NFS shares via my desktop.

scanmounts.log -
Code:
192.168.0.12 is on-line - attempting to mount omv
mount -o soft 192.168.0.12:/export/media-share /media/omv
Cheers.
 

MontysEvilTwin

Well-Known Member
Hi folks, I wonder if anyone could advise regarding a frustrating problem with an NFS mount please.

I'm accessing an NFS share on my NAS/server via the USB list but I can only see the first (top) level of files and folders under the mount. All folders appear empty. An MP4 visible on that top level that plays directly on the T2 and via DLNA does not play when accessed via the USB list, with an error of "Cannot support this file format".

I've tried altering the NFS share options on the NAS (such as "nohide" and "no_subtree_check") but to no avail. I have no problem accessing the NFS shares via my desktop.

scanmounts.log -
Code:
192.168.0.12 is on-line - attempting to mount omv
mount -o soft 192.168.0.12:/export/media-share /media/omv
Cheers.
I have seen this behaviour before but only intermittently. I think it occurs when the network connection drops. What happens if you manually unmount the share and then remount from the command line? See post #667 for example commands.
 

chimeland

New Member
I have seen this behaviour before but only intermittently. I think it occurs when the network connection drops. What happens if you manually unmount the share and then remount from the command line? See post #667 for example commands.
Hi Monty, it turned out to be a permissions issue on the NAS/server. I telneted in to the T2 and was getting a "permission denied" when having a nose around in "media/omv" with 'ls -la'. All's well that ends well!

Thanks for your time :)
 
I'd like to use this on my Fox T2 to access media on a hard drive which has been pulled from a Foxsat HDR. I've mounted the Foxsat drive in an Ubuntu server, and can see it from the USB section of the T2. The problem is that, although I can see the folders, I don't see any of the recordings in the folders (e.g. the .ts files). All of the folders seem to be empty.

Any ideas??
 

Black Hole

May contain traces of nut
IIRC, Foxsat recordings have to be naked .ts files (ie no sidecar files) to be compatible with HDR-FOX - the sidecar files are incompatible. If so, then presumably the sidecar files from the Foxsat are masking the .ts files.

You are sure the .ts files are decrypted? (That wouldn't stop them being visible, but they would refuse to play.)
 
IIRC, Foxsat recordings have to be naked .ts files (ie no sidecar files) to be compatible with HDR-FOX - the sidecar files are incompatible. If so, then presumably the sidecar files from the Foxsat are masking the .ts files.

You are sure the .ts files are decrypted? (That wouldn't stop them being visible, but they would refuse to play.)
That was it - I removed the sidecar files and now I can see the .ts files. Many thanks!
 

R7814N

New Member
In my list of recorded files on my HDR Humax I see an entry for ModSettings. Opening it and going into the nfs folder shows the setup template folders and not the media files.

I am using Ubuntu gnome 16.04 on my desktop computer.

This is what I have done so far:
I have chosen to use nfs in ModSettings. I have changed the folders in nfs to show:
  1. folder=_home_robin_humyvids
  2. host=10.10.110.18 (This is the address of my desktop computer via ip route get 8.8.8.8 | awk '{print $NF; exit}' )
  3. Sharefolder= On
The actual files are on the external HD and the partition has underscores in the name so I have created a read only folder in robin's home called humyvids which is linked to the actual folder containing the video files. I have also put an empty memory stick into the usb socket on the Humax.

What have I overlooked?
 

Black Hole

May contain traces of nut
In my list of recorded files on my HDR Humax I see an entry for ModSettings. Opening it and going into the nfs folder shows the setup template folders and not the media files...
10.10.110.18 appears incorrect. I suspect you have found the current IP address assigned to your Internet connection and not the IP address of your PC on your home network. On a Windows PC I would advise opening a command console and typing "ipconfig" to get a report of the networking parameters - you need whatever the Linux equivalent is (google it).

Leave shareholder=off until you have it working by the "normal" route. Then your share should be accessible via Media >> Storage (blue) >> USB. Once you have that working you can consider sharefolder=on, but beware of side effects.

I know nothing about configuring Ubuntu for external file access. You may need to enable NFS sharing, or configure specific folders to be shareable.
 

R7814N

New Member
10.10.110.18 appears incorrect. I suspect you have found the current IP address assigned to your Internet connection and not the IP address of your PC on your home network. On a Windows PC I would advise opening a command console and typing "ipconfig" to get a report of the networking parameters - you need whatever the Linux equivalent is (google it).

Leave shareholder=off until you have it working by the "normal" route. Then your share should be accessible via Media >> Storage (blue) >> USB. Once you have that working you can consider sharefolder=on, but beware of side effects.
Thank you for your response. I made the changes you suggested by bringing in the host computer as 127.0.0.1. Unfortunately the share still does not appear in storage>>blue. I hope someone with specialised linux knowledge will also comment.
 
Top