1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Questions from a noob

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by dazbobaby, Dec 9, 2011.

  1. dazbobaby

    dazbobaby New Member

    firstly Hi All, and thank you very much to everyone involved in the CF for the HD-Fox-T2.

    What was a great cheap HD PVR is now a belter!

    So here I go with my question/s

    I've got the custom firmware installed, configured as much as I need too (I'm also a complete idiot when it comes to linux), and everything is fine, I've even installed a few packages that I need, such as mediatomb and the Auto-Unprotect package.
    I've changed all the flags to remove the "enc" and even copied a few files from my Hummy to my PC.
    But they don't play, I can only assume they're still encrypted.

    I've also setup the virtual drive.
    Am I missing something? Do I need to do more, or should I just leave the box on and let auto-unprotect and the virtual drive do it's stuff? I thought that auto-unprotect and media tomb would let me decrypt and copy to my PC?

    Am I over simplyfying things? Is there more to do?

    Thanks for any help, and thanks again for the excellent work.
     
  2. Black Hole

    Black Hole Ron Glum

    You cannot decrypt the files with an HD-FOX - you have to run it in "HDR Mode" to get access to decryption. Please see NEW READERS START HERE (click), and refer to the entry for "HD-FOX T2" in the Glossary.
     
  3. dazbobaby

    dazbobaby New Member

    My next step is to install the HDR upgrade and bootHDR, then the scripts, I guess I just found the description of Auto-Unprotect a little misleading:
    I guess it does just the "remove the flag" and not the actual encrypted bits.
     
  4. Black Hole

    Black Hole Ron Glum

    As it says on the tin, it clears the flag which protects the encrypted content from being decrypted. I understand your confusion, many people misunderstand. The point is that ALL the recordings are encrypted on disk, but SOME content is protected from being decrypted while others are decrypted when copied off as a matter of course (except that the HD-FOX has no conventional means to do that).
     
  5. dazbobaby

    dazbobaby New Member

    hmm, I'm having a problem installing the FTP server via web, it just hangs on processing request...
    I've left it for 20 minutes, still nothing, but it shows as installed, but I can't access the box, although the FTP client seems to think it's there.

    How can install/configure tinyFTP via SSH?
     
  6. xyz321

    xyz321 Well-Known Member

    There's probably a small bug in the startup script which is causing the installer to hang. It should be installed and running though. Are you accessing it with username 'humaxftp' password '0000'?
     
  7. dazbobaby

    dazbobaby New Member

  8. Black Hole

    Black Hole Ron Glum

    You shouldn't have to do anything to install the FTP server - it's there as soon as you load the custom firmware from USB. The problem is one of accessing it, and I appeal to all newcomers please to start with NEW READERS START HERE or at the very least Black Hole's Trail Guide.
     
  9. Brian

    Brian Administrator Staff Member

    The HD-FOX T2 does Not have an FTP server built in, (unlike the HDR-FOX T2) that is why the OP was trying to install the "tinyftp" package.
     
  10. 4291

    4291 Well-Known Member

    I have no need of it at the moment, but I have installed it to see what happens. I can confirm that the installer hangs but tinyftp intalls.
     
  11. dazbobaby

    dazbobaby New Member

    Ok I know I must be doing something wrong.
    I've got the HD PVR into HDR PVR mode, but I still cannot get the files decypted and playing on my PC.

    I've made sure the all the files have the enc flag turned off by using opt+
    I've installed all the scripts, made sure they are unix compliant formatting, changed attributes to 755, and yes I've managed to turn on the HDR upgrade.

    I've copied via FTP, and via the web front end but no matter what I do they still wont play.

    Any idea's please?

    Even streaming the media via mediatomb fails.
     
  12. dazbobaby

    dazbobaby New Member

    I'm trying something else, I've just installed a second hdd and I'm copying content to that.
    No doubt it'll be ext3 too so can anyone recommend a good ext3 reader for windows?
     
  13. Black Hole

    Black Hole Ron Glum

    Sorry... I figured it would have been in the firmware rather than having to be added through the custom software packages :oops:
     
  14. dazbobaby

    dazbobaby New Member

    Yeah, sorted at last. Copy the files you want, to the virtual folder.
    Must be done with the opt+ on the human remote via the media screen.
    Then copy from there to the pc or stream it.

    Took some doing but I got there.
    Could do with a decent external hdd, my other was a 40gb and I think it's dying... 10megabytes copied in 30 minutes.
     
  15. dazbobaby

    dazbobaby New Member

    well I thought I'd cracked it, it looks like HD recordings dont work. I can see a thumbnail of the video icon on my desktop, but nothing plays the file.
    and as you can see from the uploaded image, there is a green Dec icon appended to the files in the virtual folder.
    [​IMG]
    so far only SD recordings will playback.
     
  16. Black Hole

    Black Hole Ron Glum

    What are you trying to play it with?
     
  17. dazbobaby

    dazbobaby New Member

    Windows media player and wmp classic.
     
  18. dazbobaby

    dazbobaby New Member

    Right, vlc installed and working.
     
  19. Black Hole

    Black Hole Ron Glum

    Splash Player Lite is our favourite (except it won't DLNA stream - but you're not).
     
  20. dazbobaby

    dazbobaby New Member

    I tried to stream to the PlayStation 3 and iPad, both kind of worked, but struggled like hell.
    So playback on the PC is the only way for now.

    Next silly question:
    Is it possible to copy from the humax HDD to the PC hdd via a network share, and while it copies it removes the encryption?
    ie, remove the virtual drive and transfer to a network drive instead?