1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Remote control

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by The Bogeyman, Nov 23, 2012.

  1. The Bogeyman

    The Bogeyman Member

    Hi there guys,

    I've been a silent lurker on this forum for a while and love it. Really appreciate the customised firmware. Now I'm no computer genius but have managed, using the instructions here to install 2.14 with no issues.

    I like to use the web interface, particularly the remote control for its' macros- you can fire off a set of commands at once such as to stop a show you are watching, delete it and return to the main menu. I have been using this for a few months now (just upgraded from 2.12 today) with no issues, but today (before I upgraded), I noticed that the remote control app doesn't work any more. The IP address is correct, cos the border at the top of the computer screen tells me what I am watching as usual, but the commands sent are not being obeyed. I can remotely reboot the HDR, I have updated to the latest software, done a force reinstall and another reboot, but I'm still not having any joy. It is still not obeying the remote control app. Of course the physical remote control still works.

    I hope this makes sense and that I have not rambled on too much. I also hope that I'm not missing something obvious and will get laughed at! :) Hope someone can help!

    Thanks.
     
  2. prpr

    prpr Well-Known Member

    Informed wisdom seems to be that if you did not run the prepare_for_upgrade diagnostic before upgrading, then you should run the
    fix-flash-packages diagnostic afterwards.
     
    The Bogeyman likes this.
  3. The Bogeyman

    The Bogeyman Member

    Um...... I'm a bit thick. How do I do that?
     
  4. xyz321

    xyz321 Well-Known Member

    See this link. Replace 'general' with 'fix-flash-packages', then click 'Run Diagnostic'. You will need to reboot afterwards.
     
    The Bogeyman likes this.
  5. The Bogeyman

    The Bogeyman Member

    AH I get it. Thanks for that. However the problem occurred before the update. I updated to 2.14 in order to see if that would fix it. I did try fix-flash-packages as per the instructions above and it still does not work, sadly.
     
  6. xyz321

    xyz321 Well-Known Member

    Try running the 'ir3debug_on' diagnostic in the same way as above. After a reboot it should produce some additional messages in humaxtv.log when you press the 'buttons' on the virtual remote control. This may give us some clues as to why it doesn't work for you.
     
    The Bogeyman likes this.
  7. The Bogeyman

    The Bogeyman Member

    Thanks guys....... It's sorted. I made a schoolboy error of not reading your clear instructions carefully enough. :( I wrote fix-flash-packages in the wrong bloody box. What a clown. I feel like such an idiot. Thanks for your help- it's much appreciated.
     
  8. prpr

    prpr Well-Known Member

    :rolleyes:

    :)
     
    The Bogeyman likes this.
  9. cloud9

    cloud9 Member

    I'd read it as prepare_for_upgrade was only needed if upgrading from CFW prior to 2.11. Is that not the case?
     
  10. Brian

    Brian Administrator Staff Member

    I upgraded from 2.13 to 2.14 without running prepare_for_upgrade, and have not noticed any problems.
     
  11. af123

    af123 Administrator Staff Member

    It's always needed if you install the official firmware as part of the upgrade process.
     
  12. The Bogeyman

    The Bogeyman Member

    I'm not sure the upgrade was the problem. It was not working properly before I upgraded. I bet that something happened overnight which stopped it working (it worked fine yesterday). However running that fix-flash-packages thing fixed it. That is once I put it in the correct box! :rolleyes:
     
  13. af123

    af123 Administrator Staff Member

    If your Humax ever crashes within 60 seconds of starting up then the extensions that hook into the Humax software will be automatically disabled as a safety precaution. This is probably what happened.
     
    The Bogeyman likes this.
  14. The Bogeyman

    The Bogeyman Member

    AH! It did that yesterday evening! It never occurred to me to consider it!
     
  15. Black Hole

    Black Hole Felonius Gru

    That might explain why the RC isn't working on my HD-FOX!
     
    The Bogeyman likes this.
  16. If that happens could the display show this when the hummy boots, like the Crash message? It would help for diagnostics.
     
  17. stevieboy

    stevieboy Member

    Hi, I intsalled the latest Custom Firmware yesterday. everything seemed to go OK but i am seeing a couple of issues.
    I see the same issue detailed in this post. None of the actions on the remote work. I tried doing what waas suggested in this thread but still the same.
    Any other ideas please?
    Also, don't know if it's related but I am unable to watch any of my recordings through web if. It says playing but nothing happens.

    I have read through the various topics here so please be gentle with me :) thanks
     
  18. Black Hole

    Black Hole Felonius Gru

    The RC isn't working on my HD-FOX despite a recent refresh, it might still be short of a reboot though. I will have another play later.

    When you say can't play a recording, what do you mean exactly? Click "Opt+" and then "Download"? This process depends how the web browser is configured. If it detects the .ts as a playable file type it will start a viewer app and run it. If not it will offer to save the file locally. If it detects it as playable but the config is broken so it can't actually start a player app then you might get what you are seeing - the answer is to install something like VLC so the browser can find a player.
     
  19. stevieboy

    stevieboy Member

    I have VLC installed and that works outside of this scenario. Maybe I'm doing it wrong or expecting it to do something it shouldn't.
    This is what i do:
    1) Goto Browse
    2) Find a file
    3) Click on the file name
    4) In the pop up click Play
    I see this:
    VLC PlayerNow playing: /media/My Video/Cracker/Cracker_20120226_2302.ts, 64 minutes.
    there is a Play and Stop button. Nothing happens.

    I can download and play but not play in the browser. I am using IE9. I tried in FF and it said there was a plugin missing. Tried to look for one but it came back saying none suitable found.
    Is there a plugin for IE needed?

    As for the RC. The box has been rebooted 8 or 9 times. I've been experimenting with Remote Scheduling and therefore lots of reboots.
    Thanks
     
  20. af123

    af123 Administrator Staff Member

    The play button won't work on an HD box because it doesn't have the DLNA media server.. it shouldn't really appear as an option.

    RC should be working though - if you run the ir3/debugon diagnostic and reboot, what is in the humaxtv.log file that you can view under Diagnostics?