Beta [samba] Samba 3

xyz321

Well-Known Member
Now Available in the beta repository samba 3.6.25-1. This is a cut down version of samba 3 even though the executable is still 10M. It seems to work on my box without crashing and doesn't appear to make much difference to the memory usage figures (vmstat). I tried to build samba 4 but no luck so far.

If there has been a previous version of samba installed, the smb.conf file will not be overwritten, a new one will be created as smb.conf-opkg.
It will need copying to smb.conf to use the new configuration. This new configuration has the SMB2 protocol enabled and some changes to enable username/password authentication to access the files. By default this will be username=root with no (empty) password unless it had been changed previously using the smbpasswd utility.
 
OP
X

xyz321

Well-Known Member
It should still work on Windows 7 with either the original configuration or with the new configuration (although I don't have Win 7 to test it on).
 
OP
X

xyz321

Well-Known Member
You can only use users which already exist in /etc/passwd. By default the user 'root' is configured with a null password. A different user (I would suggest using 'settop') can be configured using smbpasswd -a <username>.

smbpasswd -U <user> can be used to subsequently change a user's password.

If using a non-root user then the permissions of the files under /media must be setup to allow access to that user.
 

Black Hole

May contain traces of nut
I have installed the beta samba 3.6.25-1 on two HDRs (and left an HDR and a HD on the previous samba 2.2.12-6*). I have not fiddled with my existing smb.conf files, which was default on one (no smb.conf-opkg post-install) but not the other.

Early results: Using File Explorer Pro on iPadOS, I was able to set up and use Windows file shares automatically with the samba3 machines but not the samba2 machines**, regardless of smb.conf. This is already looking very nice. File Explorer Pro (given a few seconds) lists all the shares it can find on the network for the selected type (in this case I assume "Windows" = SMB), and clicking the specific machine instantly sets up the share and invites the user to log in (just login as blank).

* I note 2.2.12-6 is also marked as beta – I don't remember anything about that, and get no useful hits from a search nor do I have a specific thread for samba listed in my package thread index. Is it correct this is a beta? If so, what for?

** I can still set up file shares, but it is a manual process.
 

prpr

Well-Known Member
You can only use users which already exist in /etc/passwd.
Yes, I discovered that. I bind mounted that to somewhere writable and added my desired username, then was able to add an smbpasswd and it worked (testing from W7).
Whilst fiddling, I've just had a spontaneous reboot, which obviously wiped it out.
If using a non-root user then the permissions of the files under /media must be setup to allow access to that user.
Yes, that becomes a right pain. I think I might go back to using "root".
 
Last edited:

prpr

Well-Known Member
I think that means that Samba has a beta available, regardless of whether it is actually installed or not.
The beta applies to the package overall, not to the particular version you have installed.
 

MymsMan

Ad detector
:doublethumbsup: :doublethumbsup: My main laptop which, for unknown reasons, gave up on connecting via SMB1 is now back connected to my humax :doublethumbsup: :doublethumbsup:

Would it be an idea to include, commented out, the definition for access to Root in the smb.conf file then anyone who wants root access can quickly enable it?
Code:
[Root]
   comment = Root
   path = /
   public = yes
   writable = yes
   browsable = yes
   create mask = 0644
   directory mask = 0755
   hide dot files = no

If this is the Samba 3 package why is max protocol = SMB2 and not SMB3?
 
OP
X

xyz321

Well-Known Member
It worked when I tried it on Windows 10 with or without Windows SMB1 support enabled. I did have some problems browsing when SMB1 was not enabled but this might be resolved by using something like wsdd2 (see MymsMan's link to a thread above).
 

MymsMan

Ad detector
So that makes this roll-out of little use to Win10 then?
I am now using the package on Win 10 without needing SMB1 enabled,
The humax does not appear as a computer in the Network section but you can still map network links by typing the name into the Map dialogue
 
Last edited:

peterworks

Ye Olde Bowler
I am unable to get this to work when I update the smb.conf-opkg with my own workgroup name (and change it to smb.conf). I get a Microsoft log on screen.
I have tried removing the # from guest account = root and guest ok = yes but no go.
(On Windows 10)
 
Top