Beta [samba] Samba 3

MymsMan

Ad detector
I am unable to get this to work when I update the smb.conf-opkg with my own workgroup name (and change it to smb.conf). I get a Microsoft log on screen.
I have tried removing the # from guest account = root and guest ok = yes but no go.
(On Windows 10)
What are you specifying as the Share name?
Did you restart the Samba server (Services menu) after updating the smb.conf file
If you specify \\humax (or your humaxes name/ip address) and then browse does it show a list of available shares? (My Video, My Music etc)
1620312898859.png
 

peterworks

Ye Olde Bowler
My share name is H1 and it can be seen on the network when I browse for folder (as per your example). When I try to open it I get:
Capture 06-05-2021 16_12_35.jpg
I have restarted my PC and the Humax and, yes, I did stop/start the Samba service
 

peterworks

Ye Olde Bowler
For info here is my updated smb.conf file:
Code:
[global]
   load printers = no
   printing = bsd
   printcap name = /dev/null
   disable spoolss = yes
#   guest account = root
#   guest ok = yes
   security = user
   encrypt passwords = yes
   null passwords = yes
   server string = Samba HDR-Fox-T2
   workgroup = SEAVIEW
   netbios name = %h
   case sensitive = yes
   preserve case = yes
   short preserve case = yes
   hosts allow = 10.0.0.0/255.0.0.0 192.168.0.0/255.255.0.0 172.16.0.0/255.240.0.0 127.0.0.0/255.0.0.0
   dos charset = ASCII
   max protocol = SMB2

# The directories under /media are auto-generated and added to the included
# file. Any additional shares which are not under /media should be added 
# to this file (/mod/etc/smb.conf).

include = /mod/etc/smb-hotplug.conf

## Removed since it may appear as a small disk on the client
#[Media]
#   comment = Media
#   path = /media
##   public = yes
#   writable = yes
#   browsable = yes
#   create mask = 0644
#   directory mask = 0755
#   hide dot files = no
 
OP
X

xyz321

Well-Known Member
Try right clicking on 'This PC', and select Add Network Location or Map Network Drive and give the location as \\<ip address>\My Video.
 

Black Hole

May contain traces of nut
I can't make this work for inter-Fox shares.

Normally my HD-FOX has network-shares-automount access set up by SMB to the three HDR-FOXes. Now I can only "see" HDR3, which did not have the beta samba installed.

HDR1 had a customised smb.conf, so I backed that up and replaced it with smb.conf-opkg, and returned the share settings to folder=My Video (ie nominal; avoiding the special share point I previously had set up in smb.conf. However, this has not made it work.

Looking through the beta smb.conf:
Code:
# The directories under /media are auto-generated and added to the included
# file. Any additional shares which are not under /media should be added
# to this file (/mod/etc/smb.conf).
...so it should have worked with my special share point, which is a folder under /media. Access from the iPad (File Explorer app) confirms this, it can see all the folders and mounts under /media.

The only other thing I can think of is that the current CF version of cifs (2.6.18) is not compatible with this Samba3 beta. Why would that be? SMB1?

PS: I transplanted my root share from the "old" smb.conf, and have confirmed I can now see it from File Explorer. Still no-show from the HD-FOX.
 
Last edited:

Black Hole

May contain traces of nut
Ditto HDR4. For whatever reason the smb.conf which comes with the beta has the Media share commented out (not a good idea – it was enabled in the non-beta, so you are presuming nobody uses it by removing it), so I have had to un-comment it and verify I can see it from File Explorer... but again this did not made my HD-FOX NSA link to HDR4 show up.

So I removed the samba beta, removed smb.cifs, removed opkg-beta, re-installed samba... and the HDR4 share has returned on the HD-FOX as normal.

I think this is pretty conclusive evidence that samba 3.6.25-1 (β) is not compatible with cifs 2.6.18 (or perhaps the way NSA uses cifs).

Good job I did decide to test it!
 
OP
X

xyz321

Well-Known Member
It worked for me when I used it to transfer files between two boxes. I can not remember if if tried it with a null password but it definitely works if you add username=root,password=<password> to the cifs options.
 

Black Hole

May contain traces of nut
password=<password> is not an acceptable string in modsettings, the defaults are user=User and password=Password. I take it you don't use NSA (network-shares-automount). If you mean some cifs.conf, where is it?

Regardless, this needs to work out-of-the-box.
 

peterworks

Ye Olde Bowler
Update to post 29: In the 'Enter network credentials' screen I tried putting username as root and left the password blank and it worked okay.
 

Black Hole

May contain traces of nut
It's blank/empty, as detailed above.
OK, well I've tried (in [Modsettings]) user=root and password=, but to no effect. Any other suggestions before I revert?

The other thing is that I do not need to supply any credentials when accessing the SMB from File Explorer - just login with blanks.
 

peterworks

Ye Olde Bowler
Yes I have tried that but get an error message (something like username/password invalid).
I have also found that if I turn off Windows 10 smb1 client the shares disappear.
 
Top