Setting up wired network help HDR Fox Freeview

bwizz

Member
I have a fox hdr freeveiw box . I already have a wireless connection to the box and the tv portal works fine, however I am having trouble setting an acceptable address for a wired link to my computer . at the humax end it says network connected and at the computer end it says local area connected. but I can't see any files at either end. My pc's address via ip config is 169.254.219.103 sub mask is 255.255.0.0
default gateway not shown.
the pc wireless address is 192.168.1.75 sub mask 255 .255.255.0
default gateway 192.168.1.254
Can anyone help me set up the correct settings for a two way inerface
Pc is using xp.
Thanks In advance for any interest
 

HarveyB

Active Member
Can you please clarify your statement you say that your PC address is 169... And later that it's 192....
I suspect the former refers to your Humax not your PC.
In which case your Humax has failed to obtain a proper address from your router (DHCP?).
Both need to be on 192.168.1.something.
As I don't use the wifi connect from my Humax so can't say exactly what you need to do to set wifi address properly.
I do know that the hummy gets upset if your wifi password contains spaces.
 
OP
B

bwizz

Member
I have a fox hdr freeveiw box . I already have a wireless connection to the box and the tv portal works fine, however I am having trouble setting an acceptable address for a wired link to my computer . at the humax end it says network connected and at the computer end it says local area connected. but I can't see any files at either end. My pc's address via ip config is 169.254.219.103 sub mask is 255.255.0.0
default gateway not shown.
the pc wireless address is 192.168.1.75 sub mask 255 .255.255.0
default gateway 192.168.1.254
Can anyone help me set up the correct settings for a two way inerface
Pc is using xp.
Thanks In advance for any interest
They are the two address's of my pc first is the wired 169 one and the other the wifi ie 192 via ipconfig on my pc
 

MontysEvilTwin

Well-Known Member
Are you attempting a direct ad hoc connection between the PC and the Humax? If so, I'm not sure if this is possible or not. If you just want to be able to transfer files between the two, the best way is to incorporate the Humax into your network by connecting it to your router. You can do this by Ethernet or WiFi (see wiki for compatible dongle details). Edit: it sounds like you are already connected by WiFi. If you have DHCP turned on you can use automatic settings. You can the turn on the ftp server on the Humax, and use Filezilla client on the PC to move files by ftp, or if you install custom firmware you can set up samba shares. There is a lot of information in this forum and the wiki if you have a root around.
 
OP
B

bwizz

Member
I have a working wifi network, via custom firmware, I have recently added a wired patch lead hoping to be able to speed up the transfer of files, Even though the humax and pc both say connected I can not the see respective devices via wire
seems . seems the auto ip address is wrong?
ftp is turned on
 

Black Hole

May contain traces of nut
When you say you have a patch lead, do you mean directly between the Humax and the PC with no router in between? If so, you need to manually configure the IP address and net mask on either the Humax or the PC so that they can talk to each other - with no router in between there is nothing to configure a network device which requests DHCP - and even if you have manual set on the Humax, the PC will normally be DHCP.

I don't think the 169.254.219.103 net mask 255.255.0.0 you quoted in post 1 is your PC's address on your home network, I think it is your router's IP address on the Internet allocated by your ISP. For devices to communicate on your home network (or on an ad-hoc network such as a direct wire between two devices) the net masks must match (I have played with the idea of non-matching net masks and failed miserably) - normally 255.255.255.0 - and the IP addresses must match everywhere the is a binary '1' in the net mask but be different (in total) where there are '0's in the net mask.

Thus with a net mask 255.255.255.0 (255 = binary '11111111'), home network addresses are typically 192.168.1.x, and x is different for every device on the network.

To find out (and adjust if necessary) what your Humax is using, go to Menu >> Settings >> System >> Internet Setting >> Configure LAN (or Configure WiFi). I have not used WiFi and can't advise. If there is a LAN cable plugged in, I think the WiFi becomes inactive.

There is no reason to think the WiFi will slow the transfers down significantly, the Humax LAN is not particularly fast. If you have a working WiFi connection (as you seem to say), I would stick with that.

To persist with an ad-hoc cable connection, the easiest thing to do is to find out what IP address the PC defaults to (turn off its WiFi interface) by IPCONFIG and then manually configure the Humax to suit. If your PC is 192.168.1.75, the Humax can be 192.168.1.(anything except 75).
 

MontysEvilTwin

Well-Known Member
If you are directly connecting the PC to the Humax, you will need a crossover cable rather than a standard Ethernet cable.
 
OP
B

bwizz

Member
Getting a bit nearer now I think at humax end , I see pc directory listed ? My humax box is now set to manual ip the address is 169.254.219.102// 255 255.0.0 gateway address -
Pc is set to auto assign address is 169.254.219.103 sub mask 255.255.0.0 . In pc I get now connected icon but nothing when I look for workgroup computers.
this is very confusing. I'm using a normal internet multi patch lead
 

Trev

The Dumb One
It sounds like an IP address conflict or somesuch.
Have you deliberately set the IP range to 169.254.219.xxx? The default IP range for most home network router DHCP is 192.168.0.xxx or 192.168.1.xxx
I'm using a normal internet multi patch lead
To connect what to what?
the pc wireless address is 192.168.1.75 sub mask 255 .255.255.0
default gateway 192.168.1.254
This seems to be the 'standard' IP range. Your hummy and your computer and any other devices should be in the range 192.168.1.xxx with a SSM of 255.255.255.0 and ideally should all be assigned the same workgroup name.
I see pc directory listed ?
Why the question mark. Do you or don't you?
 

MartinLiddle

Super Moderator
Staff member
In pc I get now connected icon but nothing when I look for workgroup computers.
You have posted in the standard firmware section of the Forum and so I assume you do not have the custom firmware on the Humax. Without custom firmware you will not see the Humax as a workgoup computer. You can either access it with an FTP client (eg Filezilla) or via DLNA.
 

HarveyB

Active Member
Have you tried disabling the PC wired connection and then checking whether the PC and Humax can see each other.
Do the same with PC wifi connection disabled and wired enabled.

It sounds like your PC is defaulting to one (wifi or wired) IP address and the PC is on a different domain.

EDIT: I agree it sounds like the PC is set up in a strange way, is there a reason why bother network connections aren't using 192.168.1.x IP addresses?
 

dragon-it

Member
169.254 is an auto-assigned "APIPA" address. Allocated to a network card if it is connected to something but there is no DHCP server, that would normally be your router.

So something is wrong. If that is a wireless card then it isn't properly connected so that it sees it is connected but then isn't given an IP address so Windows gives it an "automatic" one.
 

HarveyB

Active Member
So it might be a good idea to disable the 169 (wired?) connection and test the humax/PC connectivity then.
The fact that the hummy can use the portal would indicate that the hummy is connected ok. So the problem is most likely confusion at the PC end.
 

dragon-it

Member
Looking back I assume you have:

PC --> wifi --> router = 192.168.x.x, mask 255.255.255.0 DHCP from router
Humax --> wifi --> router = 192.168.x.x, mask 255.255.255.0 DHCP from router
PC --> cable <-- Humax. no DHCP server so device gets "automatic address"

If you do want this way then the Humax and PC wired both need to be on a different range to the 192.168.x.x one, I would set fixed rather than leaving it to chance. The wired card should not have a default gateway set as it isn't your route to the internet.

Humax Wifi = dhcp
Humax wired = 192.168.2.1
PC Wifi = dhcp
PC wired = 192.168.2.2

Then you should be able to PING 192.168.2.1 from the PC and with the right software on the Humax connect to \\192.168.2.1 or by FTP. You can also at the same time then connect to 192.168.1.x for the Humax.

You might be easier to get a couple of "Home plugs".

Steve
 
OP
B

bwizz

Member
I am trying to a chieve a situation where I can create a folder on my pc and access it by either wifi or the wired link. to Humax
I now have a new situation where I can't do anything with the wifi.tv portal with the wired link plugged into either end , I can't seem to revert the settings where both were at least connected together with no issues
I did /can have a situation where I can access the humax files via web address /custom software on pc
 
Top