TV portal can't connect!

dougiekyle

New Member
Can anyone help me with this problem? I have two Fox T2 freeview boxes in the house and for the past three days they both show error when trying to connect to humaxtvportal.com and then the boxes freeze up until you go on standby and re-start. One is connected to the network by powerline adaptor and the other is wifi. I also have a Humax Foxsat box and it connects no problem but you can't get youtube of course. I've tried updating software, factory re-set and re-configuring the network connection but no luck.
 

Luke

Well-Knwοn Мember
I have two Fox T2 freeview boxes
Over the past couple of days this has become normal for the HD-FOX T2. Hopefully if anyone knows otherwise they will correct me.
I have a number of freeview HD Fox Humax boxes and of those I have used in the past couple of days 1.03.12 is OK, but 1.02.xx are not. Unfortunately 1.03.12 is only available for the HDR-FOX T2.

The only thing you can do is let Humax know.
Having said that, what firmware version are they running?

dougiekyle has stated that the two FOX T2 freeview boxes are unable to connect to the portal at all.
 
OP
D

dougiekyle

New Member
Over the past couple of days this has become normal for the HD-FOX T2. Hopefully if anyone knows otherwise they will correct me.
I have a number of freeview HD Fox Humax boxes and of those I have used in the past couple of days 1.03.12 is OK, but 1.02.xx are not. Unfortunately 1.03.12 is only available for the HDR-FOX T2.

The only thing you can do is let Humax know.
Having said that, what firmware version are they running?


dougiekyle has stated that the two FOX T2 freeview boxes are unable to connect to the portal at all.
I have tried custom software version 1.02.31 which didn't make any difference so am now on official version 1.02.29 which also doesn't make any difference. I get that BBC have updated Iplayer
Over the past couple of days this has become normal for the HD-FOX T2. Hopefully if anyone knows otherwise they will correct me.
I have a number of freeview HD Fox Humax boxes and of those I have used in the past couple of days 1.03.12 is OK, but 1.02.xx are not. Unfortunately 1.03.12 is only available for the HDR-FOX T2.

The only thing you can do is let Humax know.
Having said that, what firmware version are they running?


dougiekyle has stated that the two FOX T2 freeview boxes are unable to connect to the portal at all.
I have tried version 1.02.29 and custom 1.02.31 but neither makes any difference. I get that IPlayer has been updated but Luke is right I can't even connect to get internet radio which I liked (strangely enough). All I get is a message 'error occurred while trying to connect to humaxtvportal'.
 

Luke

Well-Knwοn Мember
All I get is a message 'error occurred while trying to connect to humaxtvportal'.
For HD-FOX T2s that is all I currently expected.
I'm not sure if from my post that you were expecting different or you were confirming my expectations.
Your findings do appear to confirm my view that the only thing we can each do is let Humax know.

I am suprised about how few posts there are about this.
 

Black Hole

May contain traces of nut
You might like to try the TV Portal with the HD-FOX running in BootHDR mode (custom firmware option) with 1.03.12. IIRC somebody already has, but I don't recall the outcome.

It could be there are few posts about this because a: not many people use iPlayer on their HD-FOX; b: most people who would already know about the topic I linked to in post 2.

I thought the old iPlayer wasn't being abandoned until some time in September.
 

MontysEvilTwin

Well-Known Member
The instructions for installing Boot-HDR (1.03.12) are here. This assumes that 'standard' Boot-HDR is already installed. If not, you don't have to delete the 'HDRfs' folder (or uninstall the package itself, of course). It works well. The TV tuner also works properly with 1.03.12 HDR software: it doesn't with the 1.02.20 version.
 

Luke

Well-Knwοn Мember
I thought the old iPlayer wasn't being abandoned until some time in September.
This is not the same issue. It doesn't matter what the end date of iPlayer v2 is if the FOX can't access the portal.

Do you still have an HDR using 1.02.xx? Neither my 1.02.20 HDR nor my HD-FOX can access the portal.
 

Black Hole

May contain traces of nut
Interesting:

My 1.02.20 HDR-FOX just gives a black screen when I press the TV Portal button. My 1.02.31 HD-FOX puts up a message "An error occured whilst launching the application https://www.humaxtvportal.com/".

However, using portal-xtra1 to provide short-cuts to the portal apps, I am able to access the old iPlayer directly (HDR-FOX, 1.02.20). It puts a message at the top of the screen "This version of BBC iPlayer is closing this September. See the FAQ for more.".

I stand corrected. The link I posted (post 2) is not relevant to this topic.
 

ChrisB

New Member
I have also not been able to access the TV portal for two days, and I don't think that is going to change anytime soon. You will note that the error message quoted is an application error. It is not a connection failure; if it was there would be some interval of time where it would try to connect, whereafter it would time out. It occurs immediately one tries to access TV portal. Therefore, it must be Humax themselves who are denying entry, based on the hardware and software version. It is my opinion that it's a planned obsolescence move, with the cynical aim of making you spend more money on a new PVR.

I mainly use the portal for BBC iPlayer. Only a few months ago, the BBC removed the radio component of this, putting it on iPlayer Radio application, which so far appears to be unavailable on my HD-FOX T2. From September, I understand (if that is correct) that the remainder of that particular version of iPlayer will be unavailable. Humax appear to have preempted this be effectively removing the portal, unless you have at least version 1.03.12 of the firmware, which is not available for HD-FOX T2.

My solution for the moment is to use my laptop and connect it to the telly via a HDMI cable. Why should I spend several hundred pounds on a new PVR?
 

ChrisDaniels

Well-Known Member
Its not Humax denying entry.. its a software fault on your box. Try rebooting the box several times.

If its happening immediatly, its not communicating with Humax is it unless your broadband connection is hard linked to Humax HQ.

The portal is just a web browser with the Humax tv portal being just a webpage at www.humaxtvportal.com.

If they were planning to ditch the HD Fox, they would have announced it a long time ago.
The fact that they have remained silent suggests to me that they are either working on it or planning to.
 

MontysEvilTwin

Well-Known Member
[B]@ChrisB[/B]: do you have custom firmware installed? Message no. 7 in this thread contains a link to instructions for installing Boot-HDR, based on HDR-FOX firmware 1.03.12. Once installed you can boot the HD-FOX into 'HDR Mode'. In this mode, recording functions are not available, but you get access to the portal, including a version of iPlayer that will still work in September and currently has iPlayer radio, though this may change in the future. Rebooting is all that is required to go back to regular 'HD-FOX mode'.

I have exchanged a fair few e-mails with Humax Customer Support over the last couple of weeks. They have said that they plan to update iPlayer and that this may take the form of an app update rather than a full software update. I have been trying to get confirmation that the update will work on the HD-FOX. I am quoting from e-mails below:
I said:
Thanks for the reply. To confirm, will the iPlayer update be available for the HD-FOX T2? September is only 5 days away: do you have an estimate of when the new version will be available?
The reply was as follows:
Humax Customer Support said:
No specific release date as of yet, and it will be functional on the HD-FOX T2
 

MontysEvilTwin

Well-Known Member
Its not Humax denying entry.. its a software fault on your box. Try rebooting the box several times.
It is probably just a fault. There have been many reports of the portal not working recently on the HD-FOX and the HDR-FOX and this seems to be linked to 1.02.xx firmware: HDR-FOX T2s on 1.03.12 are OK. Rebooting an HD-FOX several times in this context seems like an exercise in futility. Hopefully we will get confirmation of a fix soon.
 

ChrisDaniels

Well-Known Member
I know, not much more I can advise and I don't know if the user has been installing custom portals or not. Certainly with the custom portal it takes a few reboots to get it up and running as we overwrite the main setting file at boot which redirects the homepage.

I'm not reading to much into the spate of recent reports as it all seems to have spiked since the iPlayer announcement which makes me wonder if people are experimenting with going custom and then getting in a mess but not admitting to it for whatever reason.

Or looking at it from another angle, has the recent code change on big screen iPlayer to add the comment about it closing somehow broke the browser cache?

My first step if I were running vanilla firmware would be to factory reset and take it from there..


Sent from my iPhone using Tapatalk
 

Black Hole

May contain traces of nut
Its not Humax denying entry.. its a software fault on your box. Try rebooting the box several times.
I don't agree, I specifically tested and got the results reported in post 9. These used to work fine in that configuration so it has to be the server end. "Error occurred when launching..." is also the message you get when the Humax doesn't know the current date and fails to authenticate with the server - so you can't read much into the error message other than "something's broken".
 

ChrisB

New Member
MontysEvilTwin - I do indeed have custom firmware installed, namely 1.02.31. This gives the same application error message as the version I used to run, namely 1.02.29, which worked perfectly well until recently. I cannot see how the firmware alone on my HD-FOX T2 would cause it, nor how rebooting the box several times would help. I suspect that Humax has changed something at their end, causing an incompatibility with 1.02.xx firmware - this sort of thing does happen in the world of IT, and if it has Humax would never publicly admit it!

Thank you for your kind advice, but I think I would rather go the laptop route for iPlayer whilst this situation persists, rather than dual-booting the box in HD or HDR mode. Let's see what Humax comes up with in the near future.
 

Black Hole

May contain traces of nut
For information: "1.02.31" is a standard firmware version, not custom firmware. In this particular case, the standard 1.02.31 firmware was extracted from a user's machine and made available through the custom firmware downloads, and as the firmware on which custom firmware for the HD-FOX is currently built. The latest custom firmware for HD-FOX is 3.00 for 1.02.31, and automatically installs 1.02.31 in the process of installation.

The firmware version which is quoted on Menu >> Settings >> System >> System Information is the Humax standard firmware version; the custom firmware version appears on the front panel display during boot, and is in the lower right hand corner of the WebIF home page.
 

Luke

Well-Knwοn Мember
Its not Humax denying entry.. its a software fault on your box. Try rebooting the box several times.
I don't know if the user has been installing custom portals or not. Certainly with the custom portal it takes a few reboots to get it up and running as we overwrite the main setting file at boot which redirects the homepage.
I don't agree either.
I have a non-customised HD-FOX T2 which can no longer launch the application on the Humax server.

The HD-FOX T2 was in storage.
When I brought it out of storage the other week to see if it had the Youtube issue. I found it had version 1.02.29 (I prefer 1.02.20 but left it alone). It does not have and never has had custom firmware.
Initially I got a connection with the Portal so that I could try Youtube. I also tried iPlayer and observed the message firm iplayer that that version of iPlayer would cease in September.
I put my HD-FOX T2 back in storage but brought it out again when there were the initial reports of not being able to connect with the portal. The unmodified HD-FOX T2 can not start up the portal and the message that comes up that the application on the Humax server has errored is almost instant.

I also have 2 customised 1.02.20s and like BH have not changed them recently. They too can no longer get the standard portal up and running while a short time ago at least one of them would display the iPlayer is ending in September message.
 

prpr

Well-Known Member
Be interesting to see what a Wireshark capture of the traffic reveals... if you've got a network hub handy.
 

NEast_Ncl

New Member
Hi everyone. New to the forum, but found this thread after trying to find out why I "suddenly" couldn't connect to the Portal on Friday. I say "suddenly" since I very rarely access the portal anyway, so this could have been the case for months.

I was receiving the error message in the attached image: "An error occurred whilst launching the application https ://www .humaxtvportal.com/"

I initially tried multiple reboots (even before I looked at the forums) and even did full reboots with power off at mains. No difference.

I then verified that the problem wasn't with the router/ISP (VirginMedia) by visiting https ://www .humaxtvportal.com/ - it worked and gave me the message "Humax STB Only!". So it was definitely the box.

I verified the box's connection to the internet by using WebIF (so the LAN was working!) to update the packages - which worked (so the WAN was working too!).

After some reading, I thought it was most likely related to the Firmware and a change at the Humax end. I manually upgraded from 1.02.32 CFW 2.19 (with OTA updates off) to 1.03.12 CFW 3.00 and the portal worked straight away. Slightly different icon when loading, but very similar otherwise. I haven't found any change in the EPG which was suggested might be a problem with the newer firmware.

I obviously can't guarantee that this is a fix, but would encourage people to simply try upgrading their firmware (or reporting that the 1.02.32_2.19 works with the Portal still).

Thanks for all the help provided on these pages, and particularly for the CFW itself!

Humax HDR-FoxT2
1.03.12 CFW 3.00
 

Attachments

  • hummyportal.jpg
    hummyportal.jpg
    65.7 KB · Views: 13
Top