1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

TV Portal Won't Run

Discussion in 'HD-FOX T2 Freeview Receiver' started by Black Hole, Oct 15, 2011.

  1. Black Hole

    Black Hole Well-Known Member

    Code:
    humax# /mod/bin/busybox/date
    -/bin/sh: /mod/bin/busybox/date: not found
    humax#
    humax# ls /mod/bin
    busybox    hmt        lsof      service    ssmtp
    epg        jimsh      ntpclient  sqlite3    wget
    humax#
    humax# ls /mod/bin/busybox
    busybox
    humax#
    humax# ls /mod/bin/busybox/busybox
    /mod/bin/busybox/busybox
    humax#
    humax#
    Sigh.
     
  2. af123

    af123 Well-Known Member

    How about:

    /mod/bin/busybox/busybox date
    /mod/bin/busybox date

    ?
     
  3. 4291

    4291 Well-Known Member

    /media/drive1/mod/bin/busybox is the path on my HD.
     
  4. Black Hole

    Black Hole Well-Known Member

    Bearing in mind ntpclient is supposed to be running:
    Code:
    humax# /mod/bin/busybox/busybox date
    Thu Jan  1 00:09:19 GMT 1970
    humax#
    humax# /mod/bin/busybox/busybox date 2011.11.1-22:20
    Tue Nov  1 22:20:00 GMT 2011
    humax#
    humax#
    Still no portal though :(

    Again, the need for these convoluted commands is because of FAT32 instead of Ext3
     
  5. Black Hole

    Black Hole Well-Known Member

    Both paths point to the same place.
     
  6. af123

    af123 Well-Known Member

    If you restart the Humax software, does the portal work now?

    humax# /etc/init.d/S90settop restart
     
  7. Black Hole

    Black Hole Well-Known Member

    Success!!!!!!! :) :) :)

    Now, here's a few interesting observations (maybe):

    Run the date command and it gives the right answer (I was slightly surprised the telnet link didn't break). The screen-saver clock, which was showing the right time immediately after I got the date command to take, now shows "00:00:00". The i-plate shows "00:00 THU 01.01.1970". Run the date command again, and the screen-saver clock still shows "00:00:00", the i-plate remains the same, and the portal still works.
     
  8. af123

    af123 Well-Known Member

    Nice catch : )

    So, setting the date to something more current prior to the Humax software starting should be good enough... that can be achieved with a couple of custom scripts.
     
  9. Black Hole

    Black Hole Well-Known Member

    I'm trying to figure out how the heck I got the right time on the screen saver at one point. Why didn't ntpclient set the clock? Maybe I have to run it on the command line??

    We also have to be careful that any time-setting function doesn't over-ride an EPG time set and mess up recordings. I guess an optional install for the likes of me will sort that.
     
  10. Black Hole

    Black Hole Well-Known Member

    I have now further established that the system clock survives a warm restart. I'll find out what happens after a cold restart tomorrow!

    Update: The portal survived a brief power-down...
     
  11. Black Hole

    Black Hole Well-Known Member

    ...but not an all-day power-down.
     
  12. Black Hole

    Black Hole Well-Known Member

    I have now spawned a separate topic for system clock issues HERE (click). Any non-clock portal problem queries should remain in this topic.

    I can confirm that ntpclient updating the system clock from the Internet has solved my particular problem.
     
  13. Black Hole

    Black Hole Well-Known Member

    From the other thread:

     
  14. LesButler

    LesButler New Member

    My Portal problem is as described in redirected post above (thanks for redirecting).

    Latest is that, although clock was showing correct time, I reset with Telnet. This has made no difference and I still can't get Portal up and running. In settings internet is connected and all settings, IP address, etc, are ok. I pinged www.google.com with Telnet (22ms) and am able to Telnet the command to reset box with the HDR firmware ok. No access to web portal interface.

    I did have the web portal running fine, and had downloaded the additional files required for booting the HDR firmware ok, and its since doing this that the Portal problem arose (relevant?). When I press Portal on remote I get a brief 'connecting' message but the screen remains showing channel full screen.

    I have checked the 4 router ethernet ports, connected ok to LG Netcast, tried other ethernet cables. I can't think of anything else to try (have read through this thread and tried suggestions). If anyone can suggest anything else to try, please reply. Thanks.

    *UPDATE* When the HDR firmware is running on box, I can connect to the portal, great! No access to web portal though.
     
  15. Black Hole

    Black Hole Well-Known Member

    Try pinging the Humax portal web site (can't tell you what the url is off-hand).

    You've confused me
     
  16. LesButler

    LesButler New Member

    I don't know the Humax portal website url.

    > You've confused me

    Telnet: Boot up the HDR firmware (bootHDRmode) so I can copy/decrypt (green pie chart), then Humax portal is available and I can connect to Iplayer, etc.
     
  17. Black Hole

    Black Hole Well-Known Member

    So you can run iPlayer in HDR mode but not when running the native HD-FOX code? Seems an obvious to me: try restoring 1.02.20.
     
  18. LesButler

    LesButler New Member

    Obvious to me too, now. I'm gonna give it a go.

    *Update: Success! Humax portal working, Telnet able to boot HDR fware, but web interface not working, even with reinstalled mod, but I'll figure that out. Thanks for help!
     
  19. Black Hole

    Black Hole Well-Known Member

    Important: I have foot-noted some of the posts in the topic above - new information has come to light that trying to run the MSP on an external USB stick formatted FAT32 is like opening a can of worms. The "normal" arrangement would be to use an external HDD, formatted Ext3.
     
  20. Martin Roddam

    Martin Roddam New Member

    One question - what on Earth are Humax doing to fix this? Any suggestions from them yet? I bought an HD-FOX-T2 purely to play back recordings from the HDR and access iPlayer, but thanks to this I can't get the system time, or use the TV Portal. So, to confirm, as a consumer, I must install ntpclient in order to use the TV Portal?
     

Share This Page