1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

1.02.28 (CF 2.11)

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by af123, Jun 25, 2012.

  1. af123

    af123 Administrator Staff Member

    I've uploaded CF 2.11 for Humax firmware version 1.02.28

    Links at the usual place - http://wiki.hummy.tv/wiki/Firmware_Downloads

    It is safe to apply this one directly over the top of 1.02.27/CF2.11 if you wish, otherwise the process is:
    • Run the prepare_for_upgrade diagnostic;
    • Install the official 1.02.28 firmware;
    • Install the customised 1.02.28/2.11 firmware.
    It may take an additional reboot for all hooks to be fully active (undelete, redring etc.)

    (Btw, humax have now removed 1.02.27 from their download site)
     
    Ron Taylor, brian, AV_Mike and 3 others like this.
  2. Scuttlebroom

    Scuttlebroom Member

    Cheers AF!

    All installed and I will see how Humaxs' .28 goes compared to .27 in terms of switch on issues and factory defaults!
     
  3. damianiw

    damianiw Member

    Wow awesome speed of update to CFW :)

    my box came with 1.02.27 - CFW'd at the weekend, will probably be this weekend until I get time to update but thanks :)
     
  4. Wallace

    Wallace Slightly Pickled

    Thanks again af123, v1.02.28 plus CF v2.11 all installed and working.
     
  5. Black Hole

    Black Hole Felinos Guru

    Anybody spotted any downsides? Like inability to revert in particular??
     
  6. af123

    af123 Administrator Staff Member

    Not yet, it looks good so far. Reversion is possible (some trickery required on the HD model just as for 1.02.27).
     
  7. makem

    makem Member

    I have followed:
    • Run the prepare_for_upgrade diagnostic;
    • Install the official 1.02.28 firmware;
    • Install the customised 1.02.28/2.11 firmware.
    Both installed successfully but when I try to connect to webIF I get an unable to connect error.

    Any help please?

    EDIT: I have the amber coloured ring showing as if the customised software is not installed.
     
  8. fenlander

    fenlander Active Member

    Same here. First failure. Previously using 1.02.27 and 2.11.
    I upgraded the Humax f/w. All fine, and I could see the Hummy through webif as usual. Nevertheless, I upgraded the custom f/w and now have no connection with the box except via ftp, having first re-enabled the standard ftp server. No telnet (server refused connection), no ftp using betaftp.
    I've tried a second install of the custom f/w. The first time it paused for a couple of minutes at 79%, second time it went straight through. Same result, though.
    Where do I go from here?
     
  9. Brian

    Brian Administrator Staff Member

    I have done the same as you, and all seems to be working properly.
    My boxes have Manual configured IP Addresses which connected to webif as normal.
    I did have to perform an additional reboot to get redring working again.
     
    Scuttlebroom likes this.
  10. fenlander

    fenlander Active Member

    I'm in the process of rolling back to 1.02.20 and I see that the pause at 79% is when the official f/w updates, not the custom. I'm suspecting that I may have made a classic error with my upgrade files. Will keep you informed.
     
  11. makem

    makem Member

    My box also has a Manual configured IP Address and I can ping it and access it via the default ftp.

    I have reinstalled the customised software twice and rebooted a number of times. It still appears as if the custom software is not installed.

    I am going to start from scratch again and install both softwares.

    EDIT: I did wait at the 79% install point until it completed as this is normal.
     
  12. Brian

    Brian Administrator Staff Member

    Yes, official 1.02.28 pauses for quite a while at 79%, then has shorter pauses at 89% and 99%.
     
    Scuttlebroom likes this.
  13. af123

    af123 Administrator Staff Member

    It seems you might have mixed up the updates. After the Humax firmware upgrade you wouldn't have webif access.
     
    Scuttlebroom and makem like this.
  14. af123

    af123 Administrator Staff Member

    Yes, that's expected - I should have put it in the instructions, will edit it in now.
     
  15. Brian

    Brian Administrator Staff Member

    I thought that I remembered something about this from a previous upgrade.:)
     
  16. makem

    makem Member

    I suspected that and am presently starting again making sure no mixup.
     
  17. makem

    makem Member

    Reinstalled both softwares again and now webIF is accessible.

    I think a file mix up was responsible.

    I did notice that in the past and according to the instructions, one must make sure to rename the custom software file and that the latest update already has the correct filename.
     
  18. fenlander

    fenlander Active Member

    A lot of pilot error going on here today.:confused:
    All now well. I rolled back to 1.02.20/2.11 successfully, then re-upgraded to 1.02.28/2.11.
     
  19. Luke

    Luke Well-Known Member

    Is that trickery just for when the CF is installed? I ask because for my HD-FOX-T2 I just used the standard USB process to revert to 1.02.20 from 1.02.27.
     
  20. af123

    af123 Administrator Staff Member

    It isn't CF specific but downgrading everything including the kernel and bootloader is usually problematic on the HD model. I thought I had read somewhere on here that downgrading from .27 to .20 didn't work.