[redring] Show red LED ring when recording in standby + other options...

Ezra Pound

Well-Known Member
How long after it should have stopped? Don't forget AR 'tracks' late running programs, It's quite common for a program to start and stop 4 / 5 Mins. after it is supposed to and a lot later than that if it followed a sporting event
 

makem

Member
It is possible but I think all programs were running to time. The AR program was 20.30 Insp. G Gently and we were watching China on 4 Wheels which we started to watch after it had started recording by maybe 20 minutes. That finished 30 mins after GG had started. We then started to watch GG.

So we were some 50 minutes behind with GG and there should have been 40 minutes left to record at that time. The red ring was still on after we finished watching the GG recording.

I will watch for it happening again.
 
After Spring (well Autumn at least!) cleaning my HDR's disk I can confirm that RedRing is now working again, and doesn't seem to be slowing the box down, so I presume it was all down to my box getting clogged up and needed a dust (using the excellent fix-disk instructions!):)
 

Ezra Pound

Well-Known Member
The Redring log (you may have turn debug on) gives a very detailed description of what is happening. In the Web-If goto Diagnostics >> View log Files >> redring.log and you will get something like this NOTE I have a program running that edits out the less intersesting stuff so you will see a lot more lines in between. It shows the actual time recordings started and stopped (as long as the Humax clock is correct obviously)

Code:
[RR] Sat Sep 15 01:14:19 2012: Persistent log starting, v2.10
[RR] Sat Sep 15 01:30:30 2012: Recording start 20:'/mnt/hd2/My Video/Click/Click_20120915_0130.nts'
[RR] Sat Sep 15 02:00:33 2012: Recording end 20.
[RR] Sat Sep 15 04:29:34 2012: Persistent log starting, v2.10
[RR] Sat Sep 15 07:09:21 2012: Persistent log starting, v2.10
[RR] Sat Sep 15 07:25:22 2012: Recording start 21:'/mnt/hd2/My Video/Pet Squad/Pet Squad_20120915_0725.nts'
[RR] Sat Sep 15 07:39:30 2012: Recording end 21.
[RR] Sat Sep 15 18:19:25 2012: Persistent log starting, v2.10
[RR] Sat Sep 15 18:38:16 2012: Recording start 20:'/mnt/hd2/My Video/Wartime Farm_20120915_1838.nts'
[RR] Sat Sep 15 19:38:29 2012: Recording end 20.
[RR] Sat Sep 15 21:56:26 2012: Recording start 34:'/mnt/hd2/My Video/The Jonathan Ross Show/The Jonathan Ross Show_20120915_2156.nts'
[RR] Sat Sep 15 22:55:57 2012: Recording end 34.
[RR] Sun Sep 16 04:29:20 2012: Persistent log starting, v2.10
[RR] Sun Sep 16 07:09:21 2012: Persistent log starting, v2.10
[RR] Sun Sep 16 07:25:04 2012: Recording start 20:'/mnt/hd2/My Video/Pet Squad/Pet Squad_20120916_0725.nts'
[RR] Sun Sep 16 07:36:09 2012: Recording end 20.
/CODE]
 

makem

Member
The log:

>>> Contents of /mod/tmp/redring.log 2.22 MiB
+++++++++++++++++++++++++++++++++++++++++++++++++++++++
[RR] Sun May 13 19:34:21 2012: Persistent log starting, v1.09

Ends as:

RR] Sat Sep 15 23:08:29 2012: Play icon off.
[RR] Sat Sep 15 23:08:47 2012: Play icon on.
[RR] Sun Sep 16 00:09:24 2012: Play icon off.
[RR] Sun Sep 16 00:09:47 2012: Play icon on.
[RR] Sun Sep 16 00:09:49 2012: Play icon off.
[RR] Sun Sep 16 00:10:24 2012: Standby ring dim detected.
[RR] Sun Sep 16 00:10:24 2012: Setting LED level.
[RR] Sun Sep 16 00:10:25 2012: Standby ring dim detected.
[RR] Sun Sep 16 00:10:25 2012: Setting LED level.
[RR] Sun Sep 16 00:10:25 2012: Ring trying to go amber.
[RR] Sun Sep 16 00:10:25 2012: Setting ring brightness.[RR] Sun Sep 16 00:10:26 2012: Allowing transition.
[RR] Sun Sep 16 00:10:27 2012: Standby ring dim detected.

No recording on Sunday.
 

renzz

Member
Since putting on this latest version, I've had a few instances where the ring has gone blue rather than dim amber when the box has gone into standby (not half awake but fully asleep). This has happened mainly when it shuts down when a timer ends (but not every time), but it did it last night when I put it into standby with the remote after chase-playing something. Here's the log from the time (I put it into standby at around 22:01)

Code:
[RR] Thu Sep 20 22:01:22 2012: -> LEDControl(0x10) 00 01 00 00
[RR] Thu Sep 20 22:01:22 2012:    [ REC = OFF ]
[RR] Thu Sep 20 22:01:22 2012: REC icon off.
[RR] Thu Sep 20 22:01:22 2012: +> LEDControl(0x10) 00 01 00 00
[RR] Thu Sep 20 22:01:22 2012:    [ REC = OFF ]
[RR] Thu Sep 20 22:01:22 2012: !> LEDControl(0x10) 00 01 00 00
[RR] Thu Sep 20 22:01:22 2012:    [ REC = OFF ]
[RR] Thu Sep 20 22:01:22 2012: -> LEDControl(0x10) 08 00 00 00
[RR] Thu Sep 20 22:01:22 2012:    [ Red Ring = OFF ]
[RR] Thu Sep 20 22:01:22 2012: +> LEDControl(0x10) 08 00 00 00
[RR] Thu Sep 20 22:01:22 2012:    [ Red Ring = OFF ]
[RR] Thu Sep 20 22:01:22 2012: !> LEDControl(0x10) 08 00 00 00
[RR] Thu Sep 20 22:01:22 2012:    [ Red Ring = OFF ]
[RR] Thu Sep 20 22:01:22 2012: Recording end 20.
[RR] Thu Sep 20 22:01:40 2012: -> LEDControl(0x10) 00 00 08 00
[RR] Thu Sep 20 22:01:40 2012:    [ HD = OFF ]
[RR] Thu Sep 20 22:01:40 2012: +> LEDControl(0x10) 00 00 08 00
[RR] Thu Sep 20 22:01:40 2012:    [ HD = OFF ]
[RR] Thu Sep 20 22:01:40 2012: !> LEDControl(0x10) 00 00 08 00
[RR] Thu Sep 20 22:01:40 2012:    [ HD = OFF ]
[RR] Thu Sep 20 22:01:40 2012: -> LEDControl(0x10) 00 02 00 00
[RR] Thu Sep 20 22:01:40 2012:    [ Play = OFF ]
[RR] Thu Sep 20 22:01:40 2012: Play icon off.
[RR] Thu Sep 20 22:01:40 2012: +> LEDControl(0x10) 00 02 00 00
[RR] Thu Sep 20 22:01:40 2012:    [ Play = OFF ]
[RR] Thu Sep 20 22:01:40 2012: !> LEDControl(0x10) 00 02 00 00
[RR] Thu Sep 20 22:01:40 2012:    [ Play = OFF ]
[RR] Thu Sep 20 22:01:40 2012: -> RingBrightness(0x1a) fc
[RR] Thu Sep 20 22:01:40 2012: +> RingBrightness(0x1a) fc
[RR] Thu Sep 20 22:01:40 2012: !> RingBrightness(0x1a) fc
[RR] Thu Sep 20 22:01:40 2012: -> LEDControl(0x10) 00 00 08 01
[RR] Thu Sep 20 22:01:40 2012:    [ HD = ON ]
[RR] Thu Sep 20 22:01:40 2012: +> LEDControl(0x10) 00 00 08 01
[RR] Thu Sep 20 22:01:40 2012:    [ HD = ON ]
[RR] Thu Sep 20 22:01:40 2012: !> LEDControl(0x10) 00 00 08 01
[RR] Thu Sep 20 22:01:40 2012:    [ HD = ON ]
[RR] Thu Sep 20 22:01:41 2012: -> RingBrightness(0x1a) fc
[RR] Thu Sep 20 22:01:41 2012: +> RingBrightness(0x1a) fc
[RR] Thu Sep 20 22:01:41 2012: !> RingBrightness(0x1a) fc
[RR] Thu Sep 20 22:01:43 2012: -> RingBrightness(0x1a) fc
[RR] Thu Sep 20 22:01:43 2012: +> RingBrightness(0x1a) fc
[RR] Thu Sep 20 22:01:43 2012: !> RingBrightness(0x1a) fc
[RR] Thu Sep 20 22:01:43 2012: -> DisplayBrightness(0x19) 1d
[RR] Thu Sep 20 22:01:43 2012: +> DisplayBrightness(0x19) 1d
[RR] Thu Sep 20 22:01:43 2012: !> DisplayBrightness(0x19) 1d
[RR] Thu Sep 20 22:01:43 2012: -> RingBrightness(0x1a) 1d
[RR] Thu Sep 20 22:01:43 2012: Standby ring dim detected.
[RR] Thu Sep 20 22:01:43 2012: +> RingBrightness(0x1a) 1d
[RR] Thu Sep 20 22:01:43 2012: !> RingBrightness(0x1a) 1d
[RR] Thu Sep 20 22:01:43 2012: -> RingBrightness(0x1a) 1d
[RR] Thu Sep 20 22:01:43 2012: Standby ring dim detected.
[RR] Thu Sep 20 22:01:43 2012: +> RingBrightness(0x1a) 1d
[RR] Thu Sep 20 22:01:43 2012: !> RingBrightness(0x1a) 1d
[RR] Thu Sep 20 22:01:44 2012: -> ClockControl(0x13) 00
[RR] Thu Sep 20 22:01:44 2012: +> ClockControl(0x13) 00
[RR] Thu Sep 20 22:01:44 2012: !> ClockControl(0x13) 00
[RR] Thu Sep 20 22:01:44 2012: -> ???(0x16) 00
[RR] Thu Sep 20 22:01:44 2012: +> ???(0x16) 00
[RR] Thu Sep 20 22:01:44 2012: !> ???(0x16) 00
[RR] Thu Sep 20 22:01:44 2012: -> RingColour(0xe) 00
[RR] Thu Sep 20 22:01:44 2012: Ring trying to go amber.
[RR] Thu Sep 20 22:01:44 2012:  Changing to dim blue.
[RR] Thu Sep 20 22:01:44 2012: +> RingBrightness(0x1a) 3f
[RR] Thu Sep 20 22:01:44 2012: !> RingBrightness(0x1a) 3f
[RR] Thu Sep 20 22:01:44 2012: +> RingColour(0xe) 01
[RR] Thu Sep 20 22:01:44 2012: !> RingColour(0xe) 01
[RR] Thu Sep 20 22:01:44 2012: -> LEDControl(0x10) 00 00 01 00
[RR] Thu Sep 20 22:01:44 2012:    [ TV = OFF ]
[RR] Thu Sep 20 22:01:44 2012: +> LEDControl(0x10) 00 00 01 00
[RR] Thu Sep 20 22:01:44 2012:    [ TV = OFF ]
[RR] Thu Sep 20 22:01:44 2012: !> LEDControl(0x10) 00 00 01 00
[RR] Thu Sep 20 22:01:44 2012:    [ TV = OFF ]
[RR] Thu Sep 20 22:01:44 2012: -> LEDControl(0x10) 00 00 08 00
[RR] Thu Sep 20 22:01:44 2012:    [ HD = OFF ]
[RR] Thu Sep 20 22:01:44 2012: +> LEDControl(0x10) 00 00 08 00
[RR] Thu Sep 20 22:01:44 2012:    [ HD = OFF ]
[RR] Thu Sep 20 22:01:44 2012: !> LEDControl(0x10) 00 00 08 00
[RR] Thu Sep 20 22:01:44 2012:    [ HD = OFF ]
[RR] Thu Sep 20 22:01:44 2012: -> LEDControl(0x10) 00 80 00 00
[RR] Thu Sep 20 22:01:44 2012:    [ Disk space 1 = OFF ]
[RR] Thu Sep 20 22:01:44 2012: +> LEDControl(0x10) 00 80 00 00
[RR] Thu Sep 20 22:01:44 2012:    [ Disk space 1 = OFF ]
[RR] Thu Sep 20 22:01:44 2012: !> LEDControl(0x10) 00 80 00 00
[RR] Thu Sep 20 22:01:44 2012:    [ Disk space 1 = OFF ]
[RR] Thu Sep 20 22:01:45 2012: -> SetClock(0x3) 50 5b 92 49
[RR] Thu Sep 20 22:01:45 2012:    [ Thu Sep 20 22:01:45 2012 ]  ( 1348178505 )
[RR] Thu Sep 20 22:01:45 2012: +> SetClock(0x3) 50 5b 92 49
[RR] Thu Sep 20 22:01:45 2012:    [ Thu Sep 20 22:01:45 2012 ]  ( 1348178505 )
[RR] Thu Sep 20 22:01:45 2012: !> SetClock(0x3) 50 5b 92 49
[RR] Thu Sep 20 22:01:45 2012:    [ Thu Sep 20 22:01:45 2012 ]  ( 1348178505 )
[RR] Thu Sep 20 22:01:45 2012: -> SetWakeup(0x5) 01 50 5b ad c4
[RR] Thu Sep 20 22:01:45 2012:    [ Thu Sep 20 23:59:00 2012 ]  ( 1348185540 )
[RR] Thu Sep 20 22:01:45 2012: -> RingBrightness(0x1a) 1d
[RR] Thu Sep 20 22:01:45 2012: Standby ring dim detected.
[RR] Thu Sep 20 22:01:45 2012: +> RingBrightness(0x1a) 1d
[RR] Thu Sep 20 22:01:45 2012: !> RingBrightness(0x1a) 1d
+++++++++++++++++++++++++++++++++++++++++++++++++++++++

The interesting lines are I guess "Ring trying to go amber" immediately followed by "Changing to dim blue"
 

Ezra Pound

Well-Known Member
The "Ring trying to go amber" immediately followed by "Changing to dim blue" is normal, At this stage it is preparing to go amber. It actually goes amber (usually) with the "Standby ring dim detected." line
EDIT
Are you sure it was not Half Awake? CHECK HERE, Half Awake can be caused by by Setting an Auto Off timer without a matching Auto On timer
 
I wonder if it would be possible to do something to the 0 - 100 slider bars so it's easier to select the number that you want, at the moment it's very difficult to select the exact number, perhaps make the bar longer or add a text entry box instead?
 
OP
af123

af123

Administrator
Staff member
You can actually type over the numbers displayed above each slider if that's easier. Just enter the values you want and press save.
 

Black Hole

May contain traces of nut
Just made an AR recording which was recording whilst watching another channel and noticed the red ring was red long after it should have stopped so thought it was another I had set up. Checked the media and found nothing recording but the ring was still red. Needed to reboot to get it to turn off.

Not really a problem for me but thought it may be worth mentioning.
Same thing reported HERE.
 

makem

Member
I tried this:

1. recording 2 and watching a previous recording = turned blue after finishing recordings - no problem

2. as above but pausing the watched previous recording for 5 minutes = changed to red as first recording ended then to blue after end of second recording - no problem

3. recording 2 (both ending same time) and pausing live tv for few minutes then watching catchup = changed to red after both recordings finished - nothing showing as recording - needed to reboot to turn off the red ring

That appears to be the same reason as DragonC reported. I will repeat the same tomorrow.
 

makem

Member
Repeated (3) above but it went to blue as it should. I don't seem to be able to repeat the problem at will.
 
OP
af123

af123

Administrator
Staff member
Drat. I tried too and couldn't replicate it. If you can get it to happen again, can you grab the redring.log file - assuming you have redring debug turned on, if not could you enable that?
 

makem

Member
I have a redring log of 2.34mb from May 2012!
Looking at the night when I reported it staying on red I notice the following:

[RR] Tue Jan 22 23:34:22 2013: Recording start 52:'/mnt/hd2/My Video/Law & Order_ UK_20130122_2334.nts'
[RR] Tue Jan 22 23:34:22 2013: Recording 1
[RR] Tue Jan 22 23:34:22 2013: Ring going red.
[RR] Tue Jan 22 23:34:22 2013: REC icon on.
[RR] Tue Jan 22 23:34:42 2013: Recording start 53:'/mnt/hd2/My Video/BBC News_20130122_2334.nts'
[RR] Tue Jan 22 23:34:42 2013: Recording 2
[RR] Tue Jan 22 23:34:42 2013: Changing to purple.
[RR] +++++++++++++++++++++++++++++++++++++++++++++++++++++++
[RR] Wed Jan 23 14:41:16 2013: Persistent log starting, v2.10
+++++++++++++++++++++++++++++++++++++++++++++++++++++++
[RR] Wed Jan 23 14:41:16 2013: Recording start 36:'/mnt/hd2/My Video/The Corrie Years_20130123_1441.nts'
[RR] Wed Jan 23 14:41:16 2013: Recording 1
[RR] Wed Jan 23 14:41:16 2013: Ring going red.
[RR] Wed Jan 23 14:41:17 2013: REC icon on.

There isn't any data for the period following 23:34:42 2013 unti the middle of the following day even though it was recording two programs.

It appears to have been recording the two programs until I rebooted the box which was showing a red
ring.

Do you want the whole log as a rar file or shall I just paste the one day when I know it occurred. I don't know that date of a previous occurrence but I believe it happened on more occasions since last May.

Dec 20 has strange entries as if the box was trying to do something and kept trying.

No data for recordings from that day until Jan 4th although it was set to record and did recording quite a few programs.
I was away from 23rd to 28th Dec and it was recording regularly.

EDIT: I have been logging everything possible to log since May should you want any others!
 

makem

Member
I have just installed official firmware 1.02.29 and the corresponding customised firmware.

I now find that the red ring stays red when in standby mode. Nothing is recording.

I have not made changes to any settings since the install.

I wonder if this may be related to the above redring problem.

EDIT: I uninstalled redring and reinstalled but find the problem persists.
 

makem

Member
Have you tried rebooting, or a power off full boot?

Yes I rebooted via the remote and when that did not work I turned the power off and on again. The problem still persists.

EDIT: It may be worth mentioning that the red colour is very feint, well below the normal recording intensity.
 

Brian

Administrator
Staff member
Did you run the prepare_for_upgrade diagnostic before upgrading? I'm not sure if this is required, but I still do it.
Have you tried the fix-flash-packages diagnostic?
 

makem

Member
Did you run the prepare_for_upgrade diagnostic before upgrading? I'm not sure if this is required, but I still do it.
Have you tried the fix-flash-packages diagnostic?

No, I did not run the prepare_for_upgrade diagnostic before upgrading. No, I have not tried fix-flash-packages diagnostic as I thought uninstalling and reinstalling would have the same effect. Am I correct?

I want to try an AR recoding in standby and see what happens.

Do you think I should run the prepare_for_upgrade diagnostic and reinstall both firmwares again?

EDIT: The ring went to dim red after the recording ended whilst in standby.
 
OP
af123

af123

Administrator
Staff member
EDIT: It may be worth mentioning that the red colour is very feint, well below the normal recording intensity.

You know that dim orange in standby is the standard behaviour for the official firmware? What do you want to happen?

It's worth checking that the redring configuration is still the way that you want it - a full uninstall/reinstall may have reset it to the defaults.

It sounds like you need to ensure that Override LED Ring Brightness is enabled in standby mode.
 
Top