[network-shares-automount] package released

Gary

Member
I think it needs the username parameter specifying even though the user is ignored by the samba server, e.g. something like:

Code:
mount -t cifs //192.168.1.18/media /media/gary -o username=abc
where abc can be anything you like.

Part of the problem is that the mount command gives "invalid argument" as its default error message. If you still have problems, have a look at /tmp/log.smbd on the server.

However, you may well be better off using the automount method since the manual method will not survive a reboot. The automatic method just runs the above command on startup anyway.


Fantastic. That works. For some reason the HD thinks everything is encrpyted. Just manually decrypted a file and it plays fine. Thought I had auto-decrypt on the HDR so will have to look into that.

Will have a play and look into putting the auto mount on
 
now webif wont let me in, says i need to input username and password, arse!

now sorted this bit at least, remembered my passwords for once!!
 
OP
Drutt

Drutt

Active Member
tried again, do i have to put c: in at the start, at present i havent, just matilda_users_my music, there are sub folders after this, do i need to go deeper?
think its called HOMEGROUP on windows 7,
so its just the password etc that i use when i reboot the pc?

If you've shared the "My Music" folder, that is all you need, nothing above that. Shares using smb are just a single mount point. Any folders below that will be visible once the share is mounted.

The password is whatever you set up when you shared the folder on the PC. If you didn't set one up, then it shouldn't matter what you put in the password field.

Hope that helps...
 

Climber

Member
You can use this guide if it is of any use. My apologies if I’m interrupting anybody else trying to help.

Firstly I would undo what you have already done and after making sure that the HumaxHD reboots without locking up then follow the below guidelines.

Setup a SMB Network Share on your HumaxHD to enable access to the HumaxHDR from it.
Name the created folder HumaxHDR. Once it has been created, input the following.
Domain=Workgroup
Folder=video
Host=192_168_1_18 (this is assuming that is still your network address for the HDR?)
mac=ABABABABABAB (only needed for wakeUp)
password=Password
shareFolder=off
user=User
wakeup=off
Then restart the Humax HD box – check webif-diag-scanmounts.log to see if it has mounted and confirm by Media-blue button-USB on the remote.
------
If you are trying also to access a folder on your PC via the HumaxHD
Firstly set up a Share folder on the PC.
To create a share folder in win7 - Open Windows Explorer and select the drive or directory where you want to place the Folder. –> File New –> Folder
Name that folder -> HumaxPCMedia –> right click that newly created folder. select sharing –> advance sharing –> click on “share this folder” –> ok and close
Confirm it is shared by checking in Network –> Your PC. It should be present there.
Now setup another Network Share on the HumaxHD to enable access to the “HumaxPCMedia” from it. – Name it HumaxPCMedia
Once it has been created, input the following:
Domain=Workgroup (or whatever your workgroup is named) (To find out what it is actually named – Control Panel – System and Security – System – The name will be to the right of Workgroup. Also take a note your PC name on the same page)
Folder= HumaxPCmedia
host=the network address of your PC
mac=ABABABABABAB (only needed for wakeUp)
password=your PC access password (that’s the password you use to login to your PC)
sharefolder=off
user=your pc name (found in Control panel – System – Computer name (as above). If the name has –PC after it, ignore that part. So if it was alpha-PC – you only need to use alpha)
wakeup=off
Then restart the HD box – check webif-diag-scanmounts.log to see if it has mounted and confirm by Media-blue button-USB on the remote. This should give access to the Sharefolder on the PC.
-----------
Any additional folder/s created within the “HumaxPCMedia” shared folder on your PC will also be shared, so you can have video, music etc. as required by your personal preference.

I have more or less the above setup and it has been working for quite a long time now.
 
thanks drutt, do i need to put c: tho? also it says that the characters / and . should be input as _, but what about the backslash \ that divides the folders, can that be input as normal?
 

osmyth

Member
I have managed to mount the HDR to the HD. I can see it in the USB list but I can only see one file (the latest). I can also see the Deleted and Duplicates folders with the indication of the number of files, but there is only one file in Deleted and nothing in Duplicates (I have no other folders). It's as if it's only showing me files created after I did the mount.
Anyone have any thoughts?
Thanks.
 
it still doesnt work, uninstalled everything again, rebooted humax, added samba and the mount thing, got it to say "stuff on pc" on the usb folder, added all the relevant details in the same case as on pc, IP address with _ instead of .'s and videos as the folder, nothing!

still locks up when switched off, and another thing i noticed is that the delete fucntion wont work, the circle thing keeps spinning but nothing gets deleted until i've switched off at back and redeleted stuff

made sure i set sharing to on, read/write etc

baffled
 
some progress this time, on the webif diagnostics page it now says 21.33 KiB under the scanmounts.log file, and the unit will switch on and off again, however the 'stuff on my pc' folder has vanished in the USB folder, [mod settings] is there now tho, but empty

am i supposed to delete the mod settings folders on the humax once i've set them up?

Domain=WORKGROUP
Folder=Videos
Host=78_148_**_***
mac=ABABABABABAB
password=(my password - lower case)
shareFolder=off
user=MATILDA
wakeup=off

it all looks ok, but theres obviously something not quite right, have tried it with sharefolder=on too

any input gratefully recd please
 
i dont really know what i'm doing, looked at the diagnostics tool, and it seems that its tried and failed to mount dozens of times, changed the user and password to default and now it says failed because unit timed out, does anyone want to see the diagnostics?? its a long long list!!??
 
does this from package management mean the network-shares-automount isnt being added correctly??

>>> opkg install network-shares-automount

Installing network-shares-automount (1.3) to root...

Downloading http://hummypkg.org.uk/hdrfoxt2/base/network-shares-automount_1.3_mipsel.opk.

mkdir: can't create directory '/media/My Video/[ModSettings]': File exists

mkdir: can't create directory '/media/drive1/[ModSettings]': File exists

Configuring network-shares-automount.

Collected errors:

* pkg_get_installed_files: Failed to open /mod/var/opkg/info/reset.list: No such file or directory.
 

Black Hole

May contain traces of nut
I've not gone back through the posts... You are trying to mount a PC share on the HDR? You don't need Samba for that - the client end of Samba is CIFS, and CIFS gets loaded as a dependency of auto-mount. Samba might be confusing the issue.
 
ok ill remove samba

i think ive made some progress, at least theres stuff showing in the scanmounts.log file, thats gotta mean that i'm sharing things correctly from pc??

its prob something to do with either having a user/password or not

stuff on pc file gone again on USB and unit locking on reboot now damnit!
 
have tried with both the user=user password=password and with the PC start up username and password without success, both options say connection refused. is there any other password combo i can try?? its def not the webif password is it?

so frustrating that you poor souls are all at work whereas i'm marooned in the house in rainy south yorkshire, and no one can help me!!
 

Climber

Member
The scanmounts log growing in size is probably due to retries in getting something to mount, so it is not always a good sign. It will not increase in size once you have a successful mount. Also note that the scanmounts log takes a while to refresh itself.
am i supposed to delete the mod settings folders on the humax once i've set them up? –NO

Are you using SMB rather than NFS when setting up the mount?

Domain=WORKGROUP – Is that actually your domain name? (See my previous post on how to check in Win 7)
Folder=Videos – have you created that folder on your PC and set it to shared? Obviously you will need some files in that folder to be able to see them via Media Blue button USB, via the remote. Also see my previous post on how to set up a PC shared folder on Win 7.
Host=78_148_**_*** - That appears to be fine if it is the Network address of YOUR PC and not the Humax
mac=ABABABABABAB – leave as is
password=(my password - lower case) – it has to be the password for your PC access and in the same case
shareFolder=off – leave as is
user=MATILDA – Is that your PC user name? If so, do you usually have it in caps to access your PC?
wakeup=off – leave as is.
 
thanks for replies climber
aah i thought the scanmounts was the size of shared videos, its about a mile long now as humax keeps trying and failing to connect!
yes i'm using smb
WORKGROUP is def the domain name
videos folder was already called that, i've not created a specific folder. i'll try that next. i used yr recommended way of sharing, but i didnt get the chance to press done, it spent a few mins saying sharing folders and then flipped back to the folders display, possible problem there then??
yes def address of pc not humax
password in lower case
matilda is pc name, it came up in upper case when i checked its name, i only ever have to type in password, but i'll try lower case too
 
right i've set up humax sharing and copied a few bits into it, have set the sharing to homegroup (read/write), it still flipped back to folders after a few seconds tho, no sign of a done button to click?

i'm in the process of removing all on webif and humax, and beginning again from scratch

will report back later
 
aha, network path has now been uncovered

the full thing is:-
\\MATILDA-PC\users\matilda\Music\various series\humax sharing

it seems i've been asking it to look in the wrong folder anyway?? i thought it was called videos? should i just go for Music which would access all my files, or can i specify right down to humax sharing?
 
Top