1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

trusty 9300t finally had enough?

Discussion in 'PVR-9300 Freeview Recorder' started by hu12, Sep 2, 2016.

  1. MartinLiddle

    MartinLiddle Super Moderator Staff Member

    So do you get any error message when you try to run it? Have you tried

    /tmp/humaxrw 1: -l
     
  2. hu12

    hu12 Member

    Yes, tried with progressive number 1,2,3 etc as advised previously. Error message reads 'No such file or directory'


    Looking at permissions again if relevant - tmp file permissions - owner root and sharing protocol requires administrator to alter. Not sure
    if this possible in live USB version of OS?
     
  3. prpr

    prpr Well-Known Member

    I don't know, but I suspect that you might need to use /dev/sda or similar instead of 1: etc.

    The help is somewhat unhelpful as to what "HUMAXDISK" actually should be.
     
  4. hu12

    hu12 Member

    Ok - will try that.
     
  5. MartinLiddle

    MartinLiddle Super Moderator Staff Member

    Ok I have remembered the Linux version is different; This is copied from a post by user Bobblecat on MyHumax.org

    "I extracted humaxrw into my /Home folder and worked with the executable 'humaxrw' from there.

    In Ubuntu Linux a sata drive is defined in this form, /dev/sdX where X is the drive specified as X= a, b, c, d etc [Letters are used rather than numbers]
    The old form /dev/hdX [used in the readme] changed to /dev/sdX when sata drives came along.

    I ran 'sudo blkid' in the terminal with the Humax drive connected and identified it as /dev/sdd.

    Not surprising as I already have three drives connected and they show up as /dev/sda, /dev/sdb, and /dev/sdc.

    I had to use sudo with the commands to make them work. [sudo is superuser - a bit like admin in windows]

    So the list command looked like this:

    sudo ./humaxrw /dev/sdd -l

    That worked. I got a list of the recordings on the Humax disk.
    You will need to check the drive letter for the Humax disk on your equipment, it might not be /dev/sdd.
    I was able to go on to successfully back up from the Humax drive to my /Home folder.

    To achieve this I entered the following in the terminal:

    sudo ./humaxrw /dev/sdd -b

    The backup only took a few minutes. Really pleasing as I was dreading that it might take hours. The backed up files appeared in my /Home directory.
    The .ts files will run with no problem through VLC media player on my PC."
     
  6. xyz321

    xyz321 Well-Known Member

    Attached is version 1.15 for Linux.
    Code:
    tar xvzf humaxrw-1.15.tgz
    
    Edit: Removed original zip attachment and replaced with tgz
     

    Attached Files:

    Last edited: Sep 7, 2016
    prpr likes this.
  7. Brian

    Brian Administrator Staff Member

    If you let me know the file type extension, I will add it to the list accepted by the forum.
     
  8. MartinLiddle

    MartinLiddle Super Moderator Staff Member

    File type is tgz (Tar archive compressed with Gnu Zip).
     
  9. hu12

    hu12 Member

    This is what I got when completing the first part 'sudo blkid' with the HDD connected:
    Code:
    mint@mint ~ $ sudo blkid
    /dev/loop0: TYPE="squashfs"
    /dev/sda1: LABEL="RECOVERY" UUID="06ECC92AECC914B9" TYPE="ntfs"
    /dev/sda2: UUID="1EF8CA81F8CA56A5" TYPE="ntfs"
    /dev/sda3: LABEL="BACKUP" UUID="9630E30930E2EEE5" TYPE="ntfs"
    /dev/sdb1: LABEL="MULTIBOOT" UUID="97CE-B44B" TYPE="vfat"
    I assume these are all my windows machine and live linux (sdb1) usb. So no sign of HDD so far.
     
    Last edited: Sep 8, 2016
  10. prpr

    prpr Well-Known Member

    I find lsblk more useful.
     
  11. hu12

    hu12 Member

    OK - will try that
     
  12. Brian

    Brian Administrator Staff Member

    File type tgz has been added
     
    xyz321 likes this.
  13. MartinLiddle

    MartinLiddle Super Moderator Staff Member

    Try:
    humaxrw /dev/sdc -l
     
  14. hu12

    hu12 Member

    sudo humaxrw /dev/sdc -l - command not found

    sudo lsblk produced:

    Code:
    mint@mint ~ $ sudo lsblk
    NAME  MAJ:MIN RM  SIZE RO TYPE MOUNTPOINT
    sda  8:0  0 149.1G  0 disk
    |-sda1  8:1  0  7G  0 part
    |-sda2  8:2  0  112G  0 part /media/mint/1EF8CA81F8CA56A5
    `-sda3  8:3  0  30G  0 part /media/mint/BACKUP
    sdb  8:16  1  3.8G  0 disk
    `-sdb1  8:17  1  3.7G  0 part /cdrom
    sdc  8:32  0 298.1G  0 disk
    loop0  7:0  0  1.3G  1 loop /rofs

    sdc looks like the HDD
     
    Last edited: Sep 8, 2016
  15. xyz321

    xyz321 Well-Known Member

    Thanks, I have updated my original post.
     
  16. xyz321

    xyz321 Well-Known Member

    Try:
    Code:
    sudo ./humaxrw /dev/sdc -l
    
    assuming humaxrw is in the current directory
     
  17. hu12

    hu12 Member

    sudo ./humaxrw /dev/sdc -l - command not found

    How can I check humaxrw is in the current directory?
     
  18. prpr

    prpr Well-Known Member

    Presumably you know where you put it???
    "ls -l" to see what's there. But I'd imagine you'd know this?
     
  19. hu12

    hu12 Member

    I re-extracted humaxrw 1.5 to home file.

    re-entered command and it gave:

    mint@mint ~ $ sudo ./humaxrw /dev/sdc -l
    Partition 2: Input/output error
     
  20. xyz321

    xyz321 Well-Known Member

    I/O errors indicate a problem reading from the disk. Partition 2 is only used for storing JPEGs so it may not be a major problem providing there are no I/O errors elsewhere. You should still be able to use recovery mode, try:
    Code:
    sudo ./humaxrw /dev/sdc -l -r
    
     

Share This Page