[webif] Web Interface 1.3.x

Status
Not open for further replies.

Jfirth8187

Member
Hi there, with the new interface I am unable to use poc, redring & rs. They all sit inside of epgkeywords and when clicked the interface resets so I am unable to configure. I have tried removing and re-installin the packages but this did not work. Please can you advise. Many thanks in advance for any help and support.
 

Attachments

  • image.png
    image.png
    127.6 KB · Views: 27

Jfirth8187

Member
Just had a go and no change. They are still in epgkeywords and as soon as you click on one they expand and collapse very quickly so you can't see the settings for them.
 

Jfirth8187

Member
I can't find the package. Can I ssh and remove it? If I can how for the HDR? Or is there another way?

Thanks again.
 

Attachments

  • image.png
    image.png
    150.9 KB · Views: 11

cdmackay

Active Member
It's possible that I'm mis-reading here, but I think I see a bug in the EPG display.

In the attached pic, you can see that the current time is just after 0130; it's actually 0135. Looking at channel 15 Film 4, you see that the first prog shown is Night of the Creeps which doesn't start until 0210. Shouldn't we be seeing a small blob for the previous programme? The yellow vertical rule is clearly shown well within the prog that has yet to start.

Screen Shot 2016-06-05 at 1.36.51 am.png

Web interface version: 1.3.0-6
Custom firmware version: 3.03 (build 2368)
Humax Version: 1.03.12 (kernel HDR_CFW_3.03)

===

On an unrelated note, please consider this RFE...

If you click on the channel icon, as in the above, it changes TV to that channel.

Please considering adding this feature to the icon on the per-channel pages, e.g. epg/xservice.jim?service=xxx

thanks much indeed.
 
Last edited:
I'm getting a "Recording conflict detection" error when I've scheduled two recordings and a reminder.

Surely, if the reminder is on the same MUX, it shouldn't trigger this?

Specifically, I'm recording on BBC2 HD and BBC4 HD whilst watching a reminder on either BBC1 HD or ITV HD as shown in the attached image.

This error is only in Web-IF; there is no problem whilst actually watching.

I have been prevented from setting some recordings because of this.
 

Attachments

  • Screenshot (3).png
    Screenshot (3).png
    67.7 KB · Views: 17

Black Hole

May contain traces of nut
I would hazard a guess that the distinction between a recording event and a reminder event has slipped through the cracks, as reminders are relatively little used.
 
In truth, I rarely use reminders myself.

But I've been using them heavily to switch the channel for the 2016 European Championship matches.
 

prpr

Well-Known Member
Suggested fix for the confusion on the Diagnostics, Mux. Info. page. This will also work after the Olympics, and for those of us who don't have QVC* on our boxes.
Code:
humax /mnt/hd2/mod/webif/html/diag # diff -u mux.jim~ mux.jim
--- mux.jim~
+++ mux.jim
@@ -88,10 +88,10 @@
  "Dave" { set mux "COM5/ARQ A" }
  "4Music" -
  "Yesterday" { set mux "COM6/ARQ B" }
-  "BBC FOUR HD" -
  "BBC NEWS HD" { set mux "COM7/ARQ C" }
  "Made In *" -
  "Movies4Men" { set mux "Local" }
+  "CBeebies HD" -
  "QVC + 1 HD" { set mux "COM8/ARQ D" }
  }
  }
 
Failed setting of recordings.

I have been doing the following:-

  • Clicking on the programme name on the EPG page.
  • Hitting [Return] to 'click' the highlighted "Record Series" or "Record Programme" button.
  • Tabbing to 'click' the highlighted "Close" button.
  • Rebooting.

This appears to work as the "Restart required - Reboot now" message comes up.
However, these recordings don't appear in the Schedule.
 

Black Hole

May contain traces of nut
Failed setting of recordings.

I have been doing the following:-

  • Clicking on the programme name on the EPG page.
  • Hitting [Return] to 'click' the highlighted "Record Series" or "Record Programme" button.
  • Tabbing to 'click' the highlighted "Close" button.
  • Rebooting.

This appears to work as the "Restart required - Reboot now" message comes up.
However, these recordings don't appear in the Schedule.
Before you reboot, if you look at the WebIF schedule page the recordings should appear as pending. Are they?
 
Just did a test.

Recording appeared at top of Schedule page as Pending.

Clicked the Reboot now button...

I think that might be it.

I normally don't click the Reboot now button and so those pending recordings sit there for hours until I shut it down at night.

It is then awakened by a 4.20am reminder.

Maybe it forgets?
 

4ndy

Member
Could this be related to something I reported back in May?

https://hummy.tv/forum/threads/webif-web-interface-1-3-x.7116/#post-96683

An issue where upcoming recordings disappeared from the schedule on a manual Webif reboot.

Nobody else has reported this, or picked up on my post, but I watched it happen just as reported.

I assume that an RS scheduling reboot when the box wakes up to record is the same trigger event that I observed.

I am no longer scheduling reboots in RS, just in case.

Sent from my SM-G930F using Tapatalk
 
Status
Not open for further replies.
Top